License Error but, only on certain macines


#1

Hi All,

I work in a school with an RM CC4 network, and we have just purchased Sketchup Pro 2015. It is going to be installed in two different classrooms. I have found in one room it works fine but in another when I try to add the license I get an error saying “The license file is invalid” I use the same package for both rooms so it is the exact same license file, both machines are the same make (maybe slightly differing in age)

I have tried rebuilding one of the effected machines (thinking maybe the old version hasnt been fully installed) but I still get the same error.

Has anyone got any ideas?


#2

• run setup and the first launch with admin rights by e.g. doing a right-click and “run as admin…”
• use the right version with the provided license data, SUP2014 won’t work with a SUP2015 license (Serial starts with “Q”)

further help:
SketchUp 2015 Licensing Error Messages
Authorize SketchUp with a Network License
SketchUp Licensing Troubleshooter


#3

As we’re on a RM network I can’t run as admin, but I have added a user as a Privileged user and it works fine, also if I run it as an admin it works, however if I run it as a normal staff user I get the error so, i`m pretty sure its down to permissions of somesort but dont know what.

I have compared folder permissions on the ProgramData folder which appear to be the same, they are both only set to read/execute permissions.

I may try and up them to modify permissions and see what happens.

It is definitely the correct license information as the key begins with a ‘Q’


#4

SU needs to write the license information to the “%ProgramData%\SketchUp\SketchUp 2015” directory and therefore requires a full RW at this location.