Length Units set to "Feet and inches"


#1

My installation of SU won’t let me alter the length units to anything other than “Inches”. I want to use “Architectural” or “Fractional” formats with units such as "10’ 4-½″ . I only see “inches”, which is grayed out.


#2

“Engineering” will let you work in feet and inches … “Decimal” will allow you to select other units.


#3

You can also start a new model using one of the Architectural templates, instead of an Engineering template. (Then the units will be set for you.)


#4

Actually, they don’t (in my case at least). No matter what template I choose, the length units are grayed out at “inches”


#5

if you open a pre-existing model, your using it’s template and to change it’s units you use Window >> Model Info >> Units…

if you open from Finder or the dock does an empty ‘Untitled’ model open, or does a previous model open?

john


#6

Okay I see the issue. You are wanting a format that has been requested before, but is not yet implemented.

As Jim said, currently you can only choose the units when you select “Decimal” as the format.

When the format is either “Architectural” or “Fractional” the units will be “Inches” and no other choice is available. the unit drop-down picklist control will be “grayed out.” (Ie, there is no fractional meters allowed.)

I am “purty” sure that feet+fractional inches have been requested already. At least in a display sense. (Entering values in both feet and inches will be a challenge in the VCB, ie, Measurements box.)

There my be some extensions that can modify your dimensions to convert fractional inches to feet+fractional inches. @TIG has a plugin that may do this.


#7

john_drivenupthewall http://forums.sketchup.com/users/john_drivenupthewall SketchUp Sage
June 15
if you open a pre-existing model, your using it’s template and to change it’s units you use Window >> Model Info >> Units…

if you open from Finder or the dock does an empty ‘Untitled’ model open, or does a previous model open?

john

Visit Topic http://forums.sketchup.com/t/length-units-set-to-feet-and-inches/26484/5 or reply to this email to respond

In Reply To

dick http://forums.sketchup.com/users/dick
June 15
Actually, they don’t (in my case at least). No matter what template I choose, the length units are grayed out at "inches"
Visit Topic http://forums.sketchup.com/t/length-units-set-to-feet-and-inches/26484/5 or reply to this email to respond

To stop receiving notifications for this particular topic, click here http://forums.sketchup.com/t/length-units-set-to-feet-and-inches/26484/unsubscribe. To unsubscribe from these emails, change your user preferences http://forums.sketchup.com/my/preferences


#8

My SU always opens with the Welcome window, with the ability to choose a template or use the default template that was previously used. I think that’s the way is should work.

With regard to the units, it all may be working as it should, and maybe I’m just misunderstanding something.

When I use the “simple architectural template with units showing “Feet and Inches”, the Model Info>Units window displays “Architectural” format, with “inches” shown but grayed out. Then when I draw an object and dimension it, it displays “Feet and Inches”, e.g. 11’ 4-½″ like you’d expect. The only thing that confused me is the grayed out “inches” when I expected “Feet and Inches”. Likewise “Engineering” format has grayed out “feet”, “Fractional” format has grayed out “inches”, and “Decimal” format is selectable. When dimensioning an object, the dimension units do, in fact, display correctly.


#9

Okay then were fine, no actual technical issue. (Moving to normal category.)


#10

I like to use the “Architectural Design - Feet and inches” on occasion. Mainly for aesthetic reasons. ]
However, for most things that I model I like to use just inches as the unit I work with.

There seems to be a way to create a template. I have one in my list that I created in the past, although I have no memory of how I did it. Is it possible that I could create a template that has the bold marks at the intersections but uses inches (like in the Woodworking template) for the unit of measurement.?

Thanks.


#11

Yes there is a way to create a template. Set the Units as you wish, change the style if you want, too. Then hit File>Save as template. Give it a name and if you want it to be your default template, make sure the box is marked. Hit Save and you’re finished.


#12

What do you mean by ‘bold marks at the intersections’? Like foot marks on a measuring tape?

If so, where would you expect to see them?


#13

I expect he’s referring to endpoints which is a setting in Styles.


#14

You could, for example, create a grid-like component made of construction points at 1ft intervals, but why would you want to?


#15

Ah, I hadn’t thought of that - I hate that default setting, and always turn it off.


#16

I don’t like endpoints or extensions on while drawing, either. Once in a very great while I find endpoints can be useful in identifying exploded curves but I only turn them on for a moment and then back off. Generally I think they get in the way of drawing accurately.


#17

I have four choices in Window menu>Model Info>Units, Architectural, Engineering, Decimal, Fractional. Of these, Engineering has Feet as the hardcoded unit, Architectural and Fractional use Inches, and Decimal lets you choose.

Despite what it says, it is Architectural that displays dimensions as feet and inches, Engineering shows decimal Feet, and Fractional shows fractional inches.

Why this is like that stems probably from the history of Liberia, Myanmar and the USA, the countries that persist at using their own arcane system of measurement instead of the international metric standard.

Anssi


#18

Thank you all for the replies. I learned a lot here.
I had never changed the units on the model info window before . That will help me a lot in the future.
Also, I clearly have a lot to learn about Styles.

One more question has come up. On the Model Info > Dimensions pane there is a setting for “Leader Lines”. What does this setting effect? I tried all of the leader lines settings but couldn’t see any difference in my model.

Thanks everyone,
Eli


#19

It changes the arrowhead style on the ends of the dimension line. It won’t change existing dimensions unless you select and update them. You can modify all the dimensions in the model by clicking on Select all dimensions and then Update selected dimensions.