Length box not registering manual input when copying objects

Hi, I’ve been using sketchup for about 2 years now and have never encountered problem like this. When I select something, a line, rectangle or whatever, and copy it, sketchup won’t allow me to paste it where I want to (for example: if I’d want to copy something 1m above it, I have to draw a 1m line and then copy it). Also, when copying, the copied object doesn’t lock on either of the axes while I’m moving it around (not placing it yet; and I’ve tried using arrows on the keybord, doesn’t work). All of these problems, length box and locking axes not working, are non existent, sketchup works as well as it should, except when I’m copying something.
Thank you very much!

Use the move tool and ctrl to copy move.
Select the object, get the move tool, click and release on an appropriate point (the corner of a cube for example) tap ctrl and a tiny cross will appear, move in the direction you want to go, let go of the mouse and type 1m and hit enter.
A copy of the object should now be place 1m from the original.

1 Like

I’m copying just the way you described, but when I type 1m and hit enter nothing happens, that’s the problem. In measurements box, when copying, length option doesn’t even appear, and when I type any number it just doesn’t register.
I’ve tried reseting workspace, nothing changed, and I’ve reinstalled the program and deinstalled all extensions just in case, still nothing changed, still have the same problem

Sounds like your keyboard isn’t working. Have you got another you can try?

Well I’m typing just fine and still, when using move tool, push/pull tool and all actions except copy/paste, I don’t have any problem (when moving something, I can lock axes and type 1m, hit enter and distance does show, in the contrary to copying)

Are you seeing the little cross next to the move cursor when you do it? If not try tapping ctrl again and see if it appears.

Yes, copied version of the shape I’m copying does appear, but that copied shape can’t lock on any of the axes and measurements box doesn’t work (I mean length option in measurements box doesn’t appear at all so I can’t place copied version lets say 1m above the original shape, typing doesn’t work)

I take it this was working previously?
Was there a Windows update since it worked?

Can you record it so we can see?

You’ve referred to “copy/paste” several times. That is different from Move/Copy. There is no distance entry associated with Copy and Paste.

Are you using Copy and Paste or Move/Copy? Here’s what Move/Copy should look like.

1 Like

You solved my problem! Thank you so so much! I was using copy/paste the whole time instead of move/copy… Thanks Dave! <3

You’re welcome. To be clear, though, Box gave you those directions in his first reply to you.

Completely misread it… thank you Box as well!

It was this comment and your reply to my tiny cross question that made me resist asking you several times whether you were using copy/paste or copy/move. I thought what I had written was pretty clear and you had confirmed that you were doing it that way. So I felt if I had said, are your really sure you are using copy move not copy paste, you would have replied with, ‘of course, I know what I am doing, I’m not an idiot’ like many others do.

We do our best to give clear answers, it’s up to the reader to read them properly, we can’t read them for you.
I’m not having a go at you, just pointing out that this sort of thing happens a lot and we get berated for talking down to people if we ask basic questions to try and get to the root of an issue. Normally I wouldn’t bother making this comment, but your answer to Dave came through on my phone and popped up on my screen (in the phone holder) as I was driving home and I nearly drove off the road banging my head on the steering wheel.

I’m glad we got you sorted out in the end.:grinning:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.