Layout viewport showing shadows, but not checked or saved in SketchUp scene


#1

I have a Layout file showing shadows on my model, however the model view does not have shadows clicked on, and the scene does not have shadows saved (and the scene setting in Layout is not ‘modified’). Is this a glitch or am I missing something?


#2

Most likely this.

Share the LayOut file so we can see what is going on.


#3

Too big to upload here, but here is a link to Dropbox: https://www.dropbox.com/s/z57y3wtzavkmo9y/Layout%20shadows.layout?dl=0


#4

Try unlocking the VP layer and then right click on the a viewport. Choose Update Model Reference. Doing that here got rid of the shadows.


#5

The scenes in the model seem fine, updating the reference worked here too.


#6

I guess I wasn’t clear with my OP. I know how to remove the issue (clicking shadows on then back off is an easy option), but it seems like a glitch that the developers might want to know about, perhaps fix.


#7

I didn’t turn shadows on and then off again. The only thing I did is update the model reference so the viewport reflects the shadow setting in the scene in the SketchUp model. I don’t see that as a “glitch” for the developers to fix.


#8

Shadows aren’t set in the SketchUp scene, and were not activated using the Layout viewport controls, and the scene wasn’t ‘modified’, yet shadows were displayed. To me that indicates a glitch. If the scene was ‘modified’, I would see your point, but that is not the case. Layout elected to display shadows even though I never engaged that option for this set of views.


#9

Not currently.

If I were a detective of some sort, I would say that the shadows were originally on when the scene were assigned to the viewport.

Then, the shadows got turned off in the model, the scene were updated and the model saved.

But, the model reference weren’t updated with the old dated viewport. I would think something in the model must have changed because the shadows disappear when you update the reference.

But I’m not a detective.


#10

My money is on @IanT’s detective work.

However, this does point up one of the features of the SU/LO separation. It works the way it does for a very good reason. For example, if you want to produce a set of presentation drawings in LO, you don’t necessarily want them to change inadvertently every time you change the underlying SU file. But when you do want changes to show up, you have to remember a sequence of operations. You have to update the scene in SU. You have to save the file in SU. And then you have to update the file reference in LO. It’s a bit of a slog to be fair, but like everything, something you get used to through practice.


#11

it would be nice if you could tick what aspects of the SU-file you would need to Update, eg. ‘Geometry Only’
In LayOut the ‘modify’ indication won’t tell what is modified (the Style, the fog-settings, camerapoint, etc)
This leads to confusion:

(Free from @MikeTadros ’ s presentation on last BaseCamp)