Layout viewport doesn't change scale

In this latest Layout version, I have encountered an issue where SketchUp viewports won’t adjust their scale when I use the pulldown menu. If I try and change it to 1/8"=1’-0" from whatever random scale it started with, the menu pulldown shows it is now 1/8" but nothing changed. If I deselect and reselect the viewport it shows it is still on the random scale setting. If I try and pick 1/8" again, same thing happens. If I pick a different scale (different from the one I’m after), it will rescale the viewport and then I can pick 1/8" and it will rescale. It’s happened on multiple Layout files.

Share a LayOut file where you are experiencing this. I expect there’s an easy fix but seeing your file will go a long way to helping you get it sorted.

Do you have customized the set of scales in the preferences?

Johnson Cabin Concepts.layout (3.7 MB)

Which viewport won’t change scale? Which page?

What scale do you want to use?

I think I have created one new scale in my preferences but it is not that scale that is causing the issue. I think it is usually 1/8"=1’-0" (a default scale) that I need most often and has caused this problem on more than one file. Once I ‘fix’ it by picking a different scale and then switching to the one I want, the problem can’t be recreated. I know I have had this issue off-and-on for a number of weeks.

I’ve already ‘fixed’ the problem in that file, by picking a different scale and then re-selecting the preferred scale. I can’t recreate the problem once it’s ‘fixed’. I will need to run some tests and see if I can recreate the issue and upload another file.

I doubt it is something in the file, when you added the custom scale, did you also wind up with an extra empty scale?

Yeah. I’m not seeing any problems in the file you uploaded.

I did note a little incorrect tag usage–possibly from 3D Warehouse components–and a bunch of unused stuff in your model.
Screenshot - 10_14_2021 , 2_58_19 PM
Screenshot - 10_14_2021 , 2_58_43 PM

Johnson Cabin Concepts purged.layout (3.5 MB)

Layout issue test.layout (3.2 MB)
So, see if you can select this viewport and change it to 1/8"=1’-0". It won’t do it for me.

scale

I restored my scales to “default” and the issue still happens. I’ll have to trial-and-error a bit more to see what commonalities I can find.

I am also on 11.6 and don’t have all those scales:


It picks the one above…

Yours is only showing the metric scales. Change your setup to show imperial scales, too.

No difference, pick’s the one above the one you want:

After some more testing, I find that if I pick 1"=10’ (which is the next scale down in the list), it will show the viewport scaling to 1/8"=1’-0" (with the pulldown for some reason showing 1/8") and then if I click on the layout page once, it will change to 1"=10’. I have repeated this effect on scales higher than 1/8" (like 1"=20’) but not lower (like 1"=1’). I’m on Mac, so keep that in mind.

Maybe it’s a Mac thing. I’ll leave it in Jack’s capable hands.

Well, I am not a developer, but there might be something wrong in how LayOut handles the scales list on Mac. That’s why I was asking for the custom scales.

SketchUp developers:

Can’t you change the feature back to the previous normal version and have this new feature—that is, the feature that allows the user to write their own input in the input forms—be an option in the settings/preferences?

What exactly are you talking about? You can still create your own custom scales in LayOut 2021.