Accuate scaling in LayOut


#1

I find it very difficult to scale/crop accuratly in LayOut. When dragging the grips it either snaps to nearest line or tends to “jump” after dragging direction before scaling happens. I know I can fill inn precise measures but often need small adjustments by eye.
Also, -how can I scale from ends (cropping) without moving contents with the scaling?


#2

Are you referring to adjusting the size of SketchUp viewports in LayOut?

You can prevent the the size of the model from changing while changing the size of the viewport by ticking Preserve Scale on Resize. You can disable grid snapping and/or object snapping by turning them off in the Arrange menu.

Generally there isn’t any need to set the scale of a viewport. It’s the view of the model in the viewport you want set to a scale. You can do that by starting in SketchUp. Create a scene with the camera set to Parallel Projection and a standard view. Then, in LO, select the desired scale in the SketchUp Model inspector window. If needed, drag the edges of the viewport to adjust the size of the viewport to suit.


#3

Thank you Dave. It was the Object Snap under Arrange that caused my problem. It was adjusting the size of the viewport I meant, -otherwise I use same method as you suggest :slight_smile:


#4

I’m happy you got it sorted. Keep in mind that you will want Object Snap turned on sometimes. You might want to put a toolbar button for it on the top row or use the keyboard shortcut.