Layout update drawings

I met a problem that the drawings would not be updated automatically. Firstly, I created a model in Pro and copied in Layout. I copied a part of model in one page and modified it. The problem was the original model that I copied from wasn’t updated. Could anyone help me solve this problem?

Thank you for the help in advance.

Did you insert your model into Layout the correct way to establish a live link? Copy-Paste will not accomplish this. You need to save your file in SketchUp and then File>Send to Layout, or the send to layout button in the large toolset. Or, open Layout and File>Insert your .skp file.

Share the LayOut file and your modified SketchUp model file.

If you copied and pasted from SU to LO as @endlessfix asked, the viewports will not be tied to the original model. If you made modifications to the viewport in LayOut that change scene properties, those changes override your changes in the SketchUp model.

Thank you for your quick response. I tried to import a model from Sketchup to Layout. I created a page for the shop drawing. When I modified a small part of the model, it still cannot be updated in the whole model. Sorry, I am new to Layout.

Thank you. I want to create the drawings for the whole model as well as each section. Can I ask what are the ways that I can modify the small part of the model in a section drawing that can reflect in the whole model? Very appreciate your help.

It’s kind of difficult to know what to tell you with so little information about your project. Basically you need to create scenes in SketchUp that show your model the way you want to see it in your shop drawing. Then use those scenes for the viewports. If you need to show a section view of a part, set up that section view in SketchUp and create a scene for it. Then select that scene for the viewport in LayOut.

Yes, I got your point. I wonder if I am able to change model directly in Layout. Thanks.

No. You can’t edit the model in LayOut.

This was done in LayOut. Each view of the model or a oart of the model is tied to a scene in SketchUp. The section views come from one scene, the isometric view another scene, the plan views yet another scene and so on.

Same idea here but only three scenes.

Thank you so much for your detailed explanation. I can change one part of model and reflect in the entire model in layout the the past but don’t know why I can do it now.

I already asked you once to share the LayOut and SketchUp files so we could help you sort it out. At this point the only thing we can do is guess that you aren’t doing something correctly. Exactly what is anyone’s guess without seeing your files.

T 1.layout (674.5 KB)
Please find the file attached. I delete the handrail in the second page but it doesn’t change in the first page.

So you aren’t using scenes as I mentioned you need to do.

On page 1 the viewport is linked to a SketchUp file called Trafalgar 11. 19.skp and it’s linked to the Last saved SketchUp view. That means that if you cnage the view (camera position, zoom level, etc.) in SketchUp and update the reference, the view will change in LayOut.

On page 2 the viewport is linked to an embedded SketchUp file, not the same one used on Page 1. This implies that you did what @endlessfix guessed and copied and pasted from SketchUp to LayOut for the page 2 Viewport.

If you look at LayOut’s References in Document Setup you can also see there are two different SketchUp files.

Yes, I understand that you set up sense in Sketchup first and use the same file for layout. I just want to know if I can modify the second part model in layout directly. Because it worked in the past few weeks.

I already told you that you can’t edit the SketchUp model in LayOut. That has never been an option. If you assign tags to the various parts of the model you can control which tags are visible and which aren’t in a given viewport. You cannot change the geometry, though.

Here I opened the .Trafalgar model file, created one scene showing all of the stairs and a second one with the upper portion hidden. Then in LayOut I updated the reference, assigned the first scene to that viewport, made a copy of the viewport and selected the other scene.

You have tags in the model but they aren’t being used correctly. ALL edges and faces should be created and remain untagged. This is the result of fixing the incorrect tag usage.
Screenshot - 11_22_2021 , 2_20_32 PM

Wouldn’t hurt to purge unused stuff from your SketchUp model once in awhile, too.
Screenshot - 11_22_2021 , 2_32_13 PM

Seems like it would be a good idea to spend some time going through the educational materials on both SketchUp and LayOut at

FWIW, I made a change in the SketchUp model and saved the file.

And both of the viewports linked to the model show the update.

Thank you so much. It looks very nice. Could you please share the file with me?

T 1 stairs.layout (383.7 KB)