LayOut thinks its not a licensed SU and won't SU pro 2018

I have been using SU Pro 2018 since May 2020. As an Architect, I use SU & LO for all of my work, Design, Contract Drawings, Building Permit Application Drawings, etc.

On Thursday last week LO gave me an error message “Sorry, this instance of of SketchUp pro is not licensed” and refused to work any longer. But my copy of SU 2018 pro was NOT affected. It still works fine. But LO does not. All this after over two years of reliable functioning of both SU pro 2018 and the LO extension to SU pro 2018.

I can find no solution to the LO problem. What is going on?

I don’t know what is going on, but you should edit your license number out of your post! This is a public forum, not official support. None of us can do anything with your license except steal it.

1 Like


Have you closed SketchUp since this problem started with LayOut? Does SketchUp still work fine after a restart? Have you done a cold reboot of the computer?

I’m curious. Why did you only start using SketchUp 2018 in 2020?

FWIW, there is no official support for SketchUp 2018 but @colin might be willing to help. Of course it’s a long holiday weekend now so you might have to wait until Monday if he can help.

1 Like

Yes, Yes and Yes, in answer to your first three queries.

I was using SU Pro 2017 on my windows desktop when I tried to install it on my laptop. I had to get a copy of my license activation code to get it installed and SU Pro 2018 was the only course of action offered. (probably the 3 year vanishing support thing). So I upgraded and found 2018 very satisfactory.

Thanks for your answer. It’s appreciated.

I figured I would need to go to Colin, but I wasn’t sure, so I tried here first. I’m just going to put off clients by reason of the holiday. (Also, I got my license when I bought SU 3, so I guess I’ve become accustomed.)

Ah … I see.

I did, too.

Hopefully Colin will be able to help. Have a good weekend.

Your 2018 license looks like it should be working. If you have previously gone through the changes to even convince 2018 that you have an Internet connection, the rest should work. My 2018 LayOut is still working ok.

You could try removing the license and adding it again. I will message you the right values to use, though I’m sure you are using the right ones.

For your interest, when you first activated 2018 on any machine, that made it not possible to activate 2017 on a new machine. You commit yourself to using 2018 on the new machine. It isn’t anything to do with being past the maintenance and support period, or whether or not the version is supported by us.