Layout stacked viewport issues 2021

Multiple troubles.
Modelled and now documenting a 2 storey house on a platform floor for construction.
Have two models feeding Layout. The first (simpler) one contains Architectural CAD files/scenes for modelling/importing to Layout as background layers, and where I did most of the modelling. The second model references the first, with selected structural component’s copied and set up off to the side in order to produce fabrication drawings. As the second is referenced off the first model, it also contains the Architectural CAD files. This second model is how I would normally do such a project-all scenes in one bundle. However it contains a shed load of fabrication scenes which make modelling a chore. So I figured I’d try running two models, the first with scenes for CAD backgrounds (and remove those scenes from the second model), and the second model for General Arrangement and Fabrication Drawings.

Trouble 1. In Layout, a CAD floor plan from Model 1 is not always the same size as the 3D floor plan in Model 2. Both models scale units are set to millimeters. Both are imported into Layout at 1:100 and Preserve scale On Resize is on. When dimensioned, both imports read correct size dimensions???. The difference in size is somewhere around 100mm in both directions on a 16m x 11m house.
I have grid lines drawn to scale in Layout so I have a fixed reference for what should be the correct size of the viewports.


Relinking/re-importing both viewports gives mixed results. sometimes both are “correct”, sometimes both are “smaller”, sometimes they are different…I can’t crack the code!!!

Trouble 2. If I re-link a viewport, that view port (most times?) becomes “solid” and you cannot see the viewport underneath. This is also inconsistent and hard to reliably replicate and decipher exactly what’s going on.

All in all its stressing me the hell out with looming deadlines. Can anyone sort me out?

Probably. Would need to see your LO file, though.

Thanks Dave. Much appreciated.
Reduced pages and sanitised version of LO file attached. Drawing D192 is the one in question.
FLOOR FRAME(copy).layout (10.8 MB)

Well, so far I haven’t been able to reproduce either problem you describe. Commonly this occurs when the viewports use Last saved SketchUp view or the Camera properties have been modified in LO but I don’t see either of those issues with D092. (You wrote D192 but I don’t see that in your file.)

One thing I would recommend is that you put each viewport on a separate layer in LO so that you can access the one(s) lower in the stack without moving the upper one(s).

I also noticed incorrect tag usage. All edges and faces should be untagged in SketchUp.
Screenshot - 3_21_2021 , 8_21_20 PM

As for the background obscuring the viewport below, make sure you haven’t got Background turned on as you do in the grayed out LO-CAD plan. If that one got shifted to the top of the stack, it would obscure the other one below.

I was just heading off to bed and thought of something about your two files. It would be a good idea to set up the scenes the same way. Compare the model’s size and relationship to the edges of the model window between the two files.

In a case like this I would be inclined to use the views from the same model file instead of trying to manage it between files.

Thanks for trying Dave.
I will definitely investigate using LO layers for stacked viewport accessibility (this problem has long irritated me).
Noted on the Tag usage. As you describe is how I try to model, but I admit to sometimes fudging this when it comes to assigning tags to multiple components at the end of a model, when I should have tagged the very first instance. Will progressively clean this up in future.
On the BACKGROUND style, I tested it just now and it is not the reason for a viewport obscuring the one below. If I copy/paste the CAD background it obscures the viewport below. Change the Scene to a Joist layout, and it still obscures. Then change the Style in LO to shaded, and the problem still persists.

I will look into setting up the scenes in both models in the same way as suggested, but you’re right, all scenes from one model seems the best workaround. It is an awful lot of scenes in one model…haven’t fully implemented a new workflow to take advantage of Tags in LO.

It’s an easy thing to implement. My LO templates have three or more layers reserved for viewports. The bottommost of those layers is set as the active layer when I save the template so the first viewport is created on that layer when I add the SketchUp model. To create the next viewport for the stack I select the next layer up, copy the viewport and then right click on the page and choose Paste to current layer. If I know I’m stacking multiple viewports, I change the layer, and click Paste to current layer again. Rinse and repeat until all viewports are created. Then it’s an easy matter of working up or down through the stack changing the scenes or making the other changes. Now with the ability to control style, tag visibility, dashes, and color right in LO, I rarely need more than one scene for the viewports in the stack.

Understood. Been there, done that, got the T-shirt. Unfortunately this often comes back to haunt, doesn’t it. :wink:

I suspect some of the problem is edges in import CAD drawings having tags from the layers they were assigned. When you first import a CAD file into SketchUp, I would suggest that you run a plugin by the venerable TIG called Default Tag Geometry. It will assign Untagged to all edges and faces in the model leaving components and groups with tags. You could then purge any unused tags from the model to simplify that list.

Did you untick the Background box in the Style section of the SketchUp Model panel?