LayOut scenes won't update

To the point of exasperation. Hours trying to get the job done - which of course should have been presented hours ago.
LayOut simply will not show some scenes.
Can someone please see if the same thing happens.

NBS_QuikBuild_Extrusion_Profiles_V-5.layout (1.8 MB)
NBS_QuikBuild_Wall_System_Extrusions_V-5.skp (1.8 MB)

Well, I think you’ve kind of done this to yourself. Every viewport in the LO document shows that you’ve modified the Camera properties. This means that changing scenes won’t reflect the Camera location for the selected scenes.


If you set up your scenes correctly in SketchUp there’s absolutely no reason to modify the Camera properties in LayOut.

Reset the Camera properties for the viewports and set them up with the desired scene and don’t modify the Camera.

In short, any scene properties you modify in LayOut will override those properties from SketchUp even if you change the scene. If you want the SketchUp scene’s properties to show in the viewports you need to not override them in LayOut.

BTW, your profile says you’re still using SketchUp 2021 but you are clearly using 2023. Please update your forum profile.

Thanks for that - I never, I repeat, never fiddle with the camera properties. Don’t know that I ever have in fact, so no way I would have suspected that. Much appreciated that you did - I will brush up on that, now.

Keep the SketchUp Model panel visible while you are working with the viewports so you can see if things get modified. Evidently they are getting modified. Perhaps you are double clicking into the viewports to move the camera. That’s what appears to have happened here, for example.

As the file opened:


After resetting the camera properties.

Good luck with getting it finished soon.

I am going to blame my tools!
My mouse had become a rat (It had been a little strange lately, and would account for the double clicking you suggested might be happening).
New mouse, and no issues.
Apart from the regular barriers Layout puts up - like the attached, which perhaps you might have some clue about. Everything is square and tidy, and in groups. How do I prevent LayOut pulling those lines out of alignment?

Asset 4-100.jpg

if you double click into the viewport, that means you want to edit the view for that viewport, either the pan or orbit, perspective and so on. So that is by definition an override to the camera settings if those are saved to the scene.

If that is an deliberate act, it also means you have to be aware of the consequences of overriding the camera settings:

  • it means that when you copy an viewport to set that up for another scene, selecting that other scene will not be enough. You will still have the same view. Other features of that scene will change however, if they are not also overridden. Which tags to show will change, the style will change.

  • You can still change the view for the viewport, by keeping it an overridden viewport, and change view by selecting for instance “Top” or “Left” from the dropdown menu. Or you can “Reset” the viewport in order for it to follow the camera settings of the new scene that you have selected.

I disagree that this is a wrong way to work, but you need to be aware of what happens if a viewports camera setting is overridden. I find it to be very powerful:

  • You now dont need to pay attention to the camera settings when updating a scene in sketchup. Maybe you have zoomed in a bit and decided there’s a tag you want to turn off. No need to go back to your original “fixed” view of the scene before you do that, or fiddle with only updating some of your scenes properties. I find this to be the most effective way to make sure my viewports dont move their content around in Layout, and that means I dont have to set up working scenes in sketchup alongside my presentation scenes. So a great reduction in the number of scenes. And having the scenes I am actually going to present be my working scenes feels much more WYSIWYG.

  • Also having the camera settings overridden makes for a powerful way to combine scenes. One can have two viewports stacked, showing different things, different tags, as set up in the sketchup scene, and be certain that the view of the scene stays the same in Layout, as it is overridden.

  • Most importantly, one can reuse one scene for many viewports. Many perspective views from different angles came be made from the same scene, and viewports that show only one small portion of a scene can be easily be prepared directly in Layout. Its scope will not change, because the camera settings for the scene is overridden.

I agree that this method complicates things if you have not studied what overriding viewports really represent, and that can give some unpleasant surprises where you find that changing the scene dont do anything. But once you get familiar with overrides, you will recognise the override and just reset it if that is no longer what you need for that viewport, or just change “Top” to “Left”, or whatever.

I am more reluctant to overriding tags for a viewport, because the override is not stored as a override per tag that you have altered the status for in Layout, but rather the whole connection to the tag status for the whole scene in SU is broken. So any new tags that you introduce, and dont want to show in that scene, will then also need to be manually turned off in the Tags panel for the overridden viewport in Layout, and that can give you some surprises.

My mouse was doing that two weeks ago on my primary computer. I switched to a different mouse thinking it was the culprit but had the same behavior. Components in SU would open for editing when I thought I was single clicking. There was no issue in LayOut because I keep double clicking into viewports disabled.

Tested both mice in SU on my laptop and no errant double clicks. Middle of last week it stopped misbehaving on the primary computer. I’m blaming a Windows update but I have no evidence.