Layout rendering from Raster to Hybrid - Not responding

I did recently update my graphics driver I believe. It’s now non responding whenever I switch this file from raster to hybrid. Usually a file like this would only take a minute or so to render. Not sure what I am doing wrong here. I don’t know a lot about updating graphics cards etc.

I also have multiple files similar to edit. Thanks for your help

https://www.dropbox.com/t/iCfn3WsSmajGXz7q
Screenshot 2023-11-28 150446
Screenshot 2023-11-28 150456

Share the LO file so we can see what you are working with and see if we get different results on out machines.

Are you still using SketchUp/LayOut 2022?

Hi Dave, I am using 2023. File is in the dropbox link

I didn’t see the link. I’ll take a look now.

Please update your forum profile.

The file is rendering for me but it’s very slow. The SketchUp file is also sluggish for me. There are millions edges in the model that need to be considered when rendering as Vector. I ran CleanUp3 on your SketchUp file and this is the result.
Screenshot - 11_27_2023 , 8_28_08 PM
It has reduced the amount of geometry significantly. Maybe try that on your end and see if it works more quickly for you.

You might also consider simplifying the smaller features like the chains and the fittings. That would reduce the number of edges that need to be considered for rendering by LayOut.

1 Like


All updated. Thought I’d post my graphics driver I updated to just incase.

Thanks! I will download Cleanup3 now and let you know how i get on.

1 Like

See my edit, above.

1 Like

Unfortunately the chain etc is built in Solidworks and is transferred to me as an stl. file and I then import and make into a Sketchup component. I have noticed when importing stl. files nothing is grouped and extremely laggy until I make groups. Could this be part of the issue?

Absolutely! By their very nature .stl files are very heavy in geometry due to the triangulation that makes up the file. In many cases SketchUp doesn’t need all that triangulation and it just slows things down.

I would suggest that you also look into an extension from Mind Sight Studios called Skimp. It could do a lot of the simplification for you and make your files behave better.

1 Like

Thank you so much! I will certainly look into this. I downloaded the cleanup by thomthom, used the clean feature (thanks for this) and unfortunately its still doing the same thing and not responding. It’s strange because I’ve already been able to render all three views hybrid and create a pdf earlier so I don’t know why its doing this now.

The Not Responding message indicates it’s busy doing the last thing you asked it to do and won’t respond to further input from you until it’s done. It’s sort of saying, “Leave me alone. I’m working here.” Simplifying your model geometry will reduce the time it takes to do the rendering.

Here are a few other examples. This is after I ran CleanUp3 so the geometry count has already been reduced.

Heading for 35 thousand entities on the steering wheel.


And over 2000 entities in the screw in the center of the wheel. (I’d bet the story you’re trying to tell wouldn’t change if that screw was removed entirely. Same with the flat head screws in the mounting plate behing the steering wheel.)
Screenshot - 11_27_2023 , 9_11_15 PM
And 817 entities in just the dome of a single cap nut. That could be reduced quite a lot and still read as a cap nut. If it’s even needed at all.
Screenshot - 11_27_2023 , 9_11_59 PM

I would suggest you pore over the model closely to look for the stuff that doesn’t add important information for the way the model is being used. Get rid of it and purge the file of unused content.

1 Like

This is all really helpful, thank you. I have been playing around with the Skimp trial as well as Cleanup while i’ve waited for it to be rendered. Now that its finally rendered, I can’t export a PDF, its just stuck on this. I think I am going to call it a day! ha ha
Screenshot 2023-11-28 164548

1 Like

Check in Document Setup>Rendering. Untick the Override box. Then try the export again.

1 Like

I have also heard that the Universal Importer plugin has a polygon reducing function that can be used when importing STL and other file types.

1 Like

Yes it can do that but also reduce the polygon count from sketchup without having to import, it reduces the polygons of all the entities on the model though, it’s better to open a new file, paste there the elements that need to be reduced and paste them again in the original file.

Skimp is better imo, you get a visual look of the model with less polygons, with the universal importer plugin you get to see only after the operation is done, it can take some time if it has too many polygons and at the end the polygon reduction could be to high and the model gets messed and it’s necessary to do it again increasing the number of polygons desired.

1 Like

Thanks for this, I’ve had a play with Universal Importer. For some reason it seems to ungroup everything & mess with my materials. I can see where this will still be useful. I think I might purchase Skimp for the future. Thanks for posting a free alternative