LayOut- Render dashed tag materials etc. in Vector/Hybrid

This screenshot shows the type of dashes I’m talking about:
image

EDIT: This seems like a bug – dashes not rendering in vector / hybrid in the files attached further down the thread. DaveR’s workaround: sending the SU scene to a new LayOut file shows the dashes as expected, in Hybrid and Vector modes. Unfortunately this would mean re-doing a lot of work with labelling etc, so I will keep raster for this project. I don’t recall exactly how the problematic LayOut file was built, but it’s likely that I initially sent a viewport from SU to LayOut, and then either copied that viewport to subsequent pages, or duplicated that LayOut page. I know this wasn’t the original viewport sent.

PS This was originally modelled in SU2021 and sent to LO2021 – the dash visibility issue happened then, and persists now in SU2022. Dash style was set within SketchUp.

Dashes set for the tags will render as Vector in LayOut. If you aren’t seeing that, there’s something wrong in your setup. Share a LayOut file that shows what you are describing. Here’s an example from one of my LO projects showing the dashes with the viewport rendered as Vector.

It will also work with Hybrid rendered viewports.

Hrmmm… OK yeah you’re right! I tested a new model, copying over the group containing the dashed entities, and the dashes did render in hybrid/vector modes. Also in this test model was a neighboring wall group with a nested section plane. So I’m stumped about why it’s not working in the attached files.

You can see the 2 dashed entities in the SketchUp scene Kitch.A – fridge door swings & stairs above section – but in the LayOut page 2 (Floor Plan) they aren’t showing as dashed in vector or hybrid render modes. At least on my end.
4 Ridgeway- Remodel.layout (1.3 MB)
4 Ridgeway Remodel.skp (477.1 KB)

I am using a lot of SU extensions and can provide a list of those if needed. No LayOut extensions though. Oh and I just switched to SU 2022. Modeled this in SU2021 – problem occurs in both versions. It also occurs when I switch to the default construction document style. Note that there is a section plane nested in the wall group.

Odd. I see the steps for example should be showing dashes but aren’t. I’ll keep poking but I suspect the LO file is somehow corrupted. How did you get the viewport from the SketchUp model file?

Sending the model to a new LayOut file results in the dashes being displayed.

I don’t remember - but I usually send one to LayOut via SU file menu, then copy that viewport to other pages and change the view in the LayOut’s SU Model dropdown. In which case this viewport would be a copied one.

That method should work fine.

See my edit, above.

Playing with the line scale settings caused for me a Bugsplat, first with this version of LO. Crash #871

That was a quick! You’re a wizard. Thank you.

Thanks. Not sure I’m a wizard. Otherwise I might be able to figure out why your file isn’t showing the dashes. There’s the issue of the pointy hat with stars and moons on it, too.

I’ll keep poking at it a little bit but the expedient thing might be to start a new LayOut file.

FWIW, in my workflow I find it best to leave setting dash styles until I get into LayOut. I don’t set them in SketchUp at all.

You’re a mage at the least. yeah I’ll start a new LayOut file.

1 Like

Best or luck to you.

FWIW, I would suggest avoiding modifying the scene Camera properties as you have for this viewport. Don’t do aything in the Camera section that results in a Reset button there. Ungood things can happen if you do.

After Reset

Just realized another advantage to modifying dashes in LayOut – you can change the weight & color. I just like doing whatever I can in SketchUp so that it transfers to new LayOut files.

1 Like

That is an advantage indeed. It also means that you can choose to show objects with dashes in one viewport but not in another. I do most of the tag visibility setting in LayOut, too. I’ve found this reduces the number of scenes I need to manage in SketchUp because a single scene can do double or triple duty.

1 Like

Dashes show up in Raster rendering. They also do in vector if I set the scaling to 1 but not in Auto. Go figure. The dashes in the stair turn up or disappear when I zoom in and out. Might be because there are two lines coinciding - I couldn’t make the dashes appear in PDF export. Fridge doors do show dashes.

1 Like

This seems like a bug. What would be an effective way to report it?

It might be a bug although I’ve not seen it before. I expect that @adam will see this thread.

Vector and Hybrid modes do still, after all these years , have problems with lines. Mostly it is apparently random missing lines, but I think the one discussed here is yet another manifestation of some fundamental thing. For this reason I use Vector rendering only when exporting to DWG, and Raster otherwise, with High export quality and no JPEG compression.
@adam might also see something in my crash.

OK, the stairs not showing dashes was a separate issue – there were pairs of lines, stacked vertically (bottom of riser and top of riser). When I deleted one of each pair, the dashes show up. I guess the 2 dashed lines were “out of phase” and appeared as a single solid line.