Dotted lines no showing in layout

Dotted lines placed on separate tag work fine in Sketchup model, but when i update layout they are showing as solid lines. It works fine if i select raster but not on hybrid or vector.

Share the LO file so we can see exactly what you’ve got. How are the dotted lines created? As guides? If you are using guides, those are a raster-only thing and will show only when the viewport is rendered as Raster or Hybrid but not in Vector.

There’s better ways to show dotted/dashed lines in LayOut.

Dave, sorry for the delay in sharing the file, unfortunately when I tried to save it on a blank title block and things went haywire. The dotted lines now seem to be working in LO so presume there must be different settings on the templates.

the file size is 35MB but for some reason it wont allow me to upload, it gets to about 20% then says error please try again

35 Mb is considerably more than the forum’s limit for uploaded files. Upload your file to Drop Box and share the link.

I see several strange things. In your LayOut file the lines you indicate should be dotted (dashed) show in Raster but not Vector or Hybrid rendering. Looking at your model I see you are tagging loose geometry which is not good practice but I also see that when I put those edges into a group, correctly untag the edges and tag the group, the dashes don’t appear. Even using a newly created tag with a dashed style doesn’t work.

I copied the geometry that shows in your Scene 10 into a new file. I assigned the ‘Dotted line’ tag to the group leaving the edges inside the group untagged as they should be. The edges are displayed with dashes as expected. This is from the new .skp file. I added some temporary geometry to expand the bounding box so you can see that the edges are showing with dashes.

Here’s the viewport in a new LO file rendered as Hybrid with the dashes showing like you would expect.

From what I can see it looks to me as if there’s an issue related to the SketchUp file. From looking at it I assume this is from a CAD import. I wonder if there’s some sort of corruption caused by that. Could you share that CAD file? I’d be interested in trying to import that into a new SketchUp file to see if I can duplicate the result you ended up with here.

Another odd, but I expect unrelated, thing in your LO file is there appear to be two references to the same .skp file. Purge removes one of them. How did you add the SketchUp file to the LayOut project?

Regarding file size, purging unused helps a lot. I purged unused stuff from your SketchUp model and purged the extra reference in LayOut. This reduced the file size from nearly 33 Mb to less than 2 Mb. A little over 94% reduction.
Screenshot - 8_4_2021 , 8_27_07 AM

I also fixed the incorrect tag usage.
Screenshot - 8_4_2021 , 8_49_21 AM

If you are using imported CAD files the first thing you should be doing after importing is making sure the geometry is all untagged.

Thank you, for such a detailed answer and explanation, having such benefit of your knowledge is much appreciated, I’m very grateful.
It certainly an uploaded CAD file as you correctly thought, I didn’t un tag the geometry after it was imported either. I tagged lose geometry (solid lines) whenever I needed a dotted or broken line as i wasn’t sure how it should be done.
Layout file stopped updating changes made to the SU file , and think I messed it up by clicking on the relink icon and reselecting it, probably the cause of it having 2 references?
Re the original cad file, presumably I can remove once you have downloaded it ?

When I looked at the file, the problem seemed to be with the dashes scale setting. When I switched to anything else than Auto, the dashes appeared, in Vector rendering too. (the right side box beside the Line Scale box). The Auto setting might be, again, something that works only with Imperial units.
I didn’t do anything else.

1 Like

Really helpful, I didn’t know about this setting or realise that it’s possible to change the length of the spacing between dashes and dots.

Generally the best way would be to collect the edges into a group or component and give that group or component a tag.

That shouldn’t create a second reference although it might if you did it from the SketchUp Model panel and relinked only one viewport.

Yes or maybe better would be to send it to me in a private message. Click on my name and then ‘Message’.

That’s interesting. I wonder what it is about the SketchUp model that prevents dashes from being displayed in the model.