Layout problem: memory consumption increases then program freezes

Hi, this is a problem that’s come up in the last few days on a couple of my projects: while annotating a viewport in Layout the program will get more and more laggy and eventually will freeze. Meanwhile, as shown on the Activity Monitor, the amount of system memory being used by Layout goes from a few hundred MB to higher and higher levels - up to 300 GB or more in cases. Then I have to force quit and reboot, only to have it happen all over again. I have a later 2013 iMac running Catalina, with 3.5 GHz Quad-Core Intel Core i7, 16 GB 1600 MHz DDR3 and NVIDIA GeForce GTX 780M 4 GB video card. I have disabled all but a couple of my Extensions (Vali’s Instant Cladding, Enroths Texture Positioning and Fredo6 FredoScale) but it did not help. Can anyone help? Thanks!

1 Like

I have seen that happen, and it appears to be caused by the time it takes to make the page thumbnails. I haven’t tracked down what causes it yet, but it seems to depend on the nature of the SketchUp model in some way.

Would you be able to send your LayOut and SketchUp file to me? You can send a direct message if you would rather not include a link in this topic.

Another possible option that can happen with mac is runaway memory caused by 3d connexion space mouse. Obviously if you don’t have one that can be ruled out.

Thanks. No, I don’t have the 3D mouse you speak of. It does seem like a runaway memory issue though.

So far as I know the runaway memory bug in the 3DConnexion drivers for Mac was fixed a few releases ago. If a user of their gear hasn’t updated the driver for years they should do so - which is not to say that newer drivers are bug free, just that this bug has been fixed.

I’m aware it has been fixed, just asking the question to rule it out.