Layout Pro 2017 problem exporting to PDF (still, apparently)

I have a 9-page LO file. I am continually updating it adding notes, dimensions, yadda yadda. Yesterday, I was able to export the entire file (all 9 pages) to PDF without difficulty. Today, when I try that, I get that error “there was a problem…” (you know the one: with only an OK button, no explanation?). So, OK, I tried exporting pages individually. That worked, all except for page 4. Huh. So I rebuilt page 4. Not an issue…it’s just notes on a referenced model view. The same model in all the other pages. I tried writing the PDF to different directories, to different computers on my network, No dice. Even tried a different file name. Nada.

The same model is referenced in three other LO files and they ALL export to PDF just fine. So, something on that one page is corrupt? How do I go about finding out what that is? Someone should encourage the coders at Trimble to provide more informative error messages.

If there’s a solution for this already in this place, please point me to it.

1 Like

Will it export without the notes, or with the notes moved to one side? Is the model using Raster, Vector or Hybrid rendering?

The PDF format is sometimes touchy, especially with graphical elements overlapping each other. I have had similar problems with AutoCad when large scanned images have been overlaid with vector lines, wipeout regions and text.

It would be helpful to see the LayOut file? Could you share it?

What is it on Page 4 that is creating the problem? Is the text imported files(s)? Or did you enter the text into text boxes manually?

Could you please complete your profile with SketchUp version, operating system and graphics card? That information helps us help you.

Guys: Thanks for responses.

The layout file references a single model. It is structural framing plans and sections for a house. Each page (in this case) displays a different view of the model. The frames that display these views are on layer “Unique Elements” which is normally locked so they hold position while I add notes, dimensions, poche, etc., and move stuff around. This is no different than any of the other pages in the 9-page set other than the view displayed and the additional info added. In this case, some dashed lines, a couple of notes, and stuff that appears “on every interior page” like grid lines and section flags.

The model is referenced using a simple hidden line style. Some of the pages utilize a hidden line style with sections on. I use no images, depending on Layout’s patterns for fills, materials, etc. Really old-school drafting style. All black and white. So no raster, no hybrid. I entered all text using Layout: nothing imported except pattern files (Layout library) and the model. No, it did not export with added items removed.

I am using Windows 7, 64 bit on a Dell Precision 3520, using a NVidia quadro 2000. Sketchup/Layout version 2017 Pro.

I was under a deadline. Couldn’t wait. I deleted Page 4 and started over. Copied a refrence frame from another page, changed the view. Fortunately the notes and stuff weren’t extensive on this page and I was able to make deadline by re-entering everything.

The result exported to PDF just fine. Problem (this one) solved. Therefore, DaveR, it doesn’t really make sense to share the file, since It’s just disconcerting to have something like this happen. I’m really glad it wasn’t a major floor plan with a gazillion dimensions and notes and call outs.

Thanks again for your responses.


Does this mean you selected a different scene in the SketchUp file?

Hi Dave:

I guess in some ways, I’m still a noob when it comes to the elegance of operating LO. Here’s the method I use to create a new page:

Let’s say I have a house model with saved scenes: FDN, FLOOR, ELEV1, ELEV 2 (etc).
I begin with a page based on a template I created (with my title block and other stuff).

I insert the model, which automatically makes a window that I can resize, change scale, and select a view. Let’s say on page one I pick FDN scene. I get it all set up scale wise and so on. This is Page 1

Now I add Page 2. It’s blank except for the title block and other stuff that appears on all pages. But there’s no model on it. So I go back to Page 1, select the frame with the FDN scene, copy it, move to Page 2, paste the frame.

Assuming I’ve set up the scenes properly in SU, I merely have to change the view (LO’s term for scene) to show FLOOR. Scale is all set up, everything fits. So far, so good.

Now I need elevations, sections, etc. I do the same thing: copy the frame, paste it on the new page, adjust sizes (for elevations), and so on. Maybe there’s another way to do this, but this method is fairly easy on my head and except for that one instance where the page wouldn’t export to PDF, I’ve had no problems.

(Now, if I’d only remember to lock the Unique Items layer before messing around with notes and dimensions, things would be all hunky dory.) :wink:

Thanks again,
ThomP (no relation to ThomThom)

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.