Layout not inserting model

Hi guys,

I’m new to Layout and have been using Sketchup for two years now. I can’t seem to insert my model/viewport into a Layout document and need to figure it out today for my job.

My understanding from Sketchup’s FAQ and Aron’s youtube tutorial is that if I click File>Insert>select my model>Open, it’ll appear on my screen in a viewport. But when I do this, nothing happens whatsoever. When I do a selection window or Ctrl A, nothing is selected so I’m assuming that means nothing happened. Is this a settings thing? What do I do?

Any help is welcomed, thanks guys.
Daly

From within SketchUp you will find that in the Large toolset there is an icon at the bottom of the left column that will accomplish the task.

Are you selecting the .skp file? What happens if you use File>Send to LayOut in SketchUp?

Hi friends,

Thanks so much, RLGL & DaveR, for responding so quickly. I was not aware of the Send to Layout function, but regardless, it did not work. See my first image. When I clicked either the Send to Layout icon or File>Send to Layout, it opened a new tab in Layout, gave me some sort of starter titleblock, but no viewport. You’ll notice on the far right that even though I selected everything on the page the “Sketchup Model” panel says I have no model selected.

Dave, the second image shows the file I’ve been trying to select. Definitely the .skp file I always use to work on this model. I have no idea what’s going on.

Also, I’m waiting to hear back from Support as they misunderstood my problem to be that I was having trouble relinking/updating scenes etc. They do not seem to understand that I literally have no viewport within which to update a model! ha

Would love to hear your thoughts.

More questions. When you installed SketchUp 2021 did you right click on the downloaded installer and choose Run as administrator? If you didn’t or don’t remember, close both SketchUp and LayOut. Find the installer–probably still in your Downloads folder–right click on it and choose Run as administrator. If the option to repair pops up, choose it. Then try again.

There is an oddity in LayOut, in that it doesn’t complain if you try to open something that won’t open. It also silently fails to tell you when LayOut itself failed to open.

If you have LayOut 2020 open for example, and attempt to open LayOut 2021, nothing happens. If you try to open a LayOut 2021 file in 2020, nothing happens. If you try to insert a SketchUp 2021 file into LayOut 2020, you get no viewport, and no error.

Are you sure that it’s LayOut 2021 that you have open?

And there is always plan B. Open Layout and select your template then go to > file > insert and select the SketchUp file you wish to open.

Colin that was it! I didn’t realize I was using Layout 2020. DaveR that was also helpful, as it reminded me to uninstall and reinstall just in case. I appreciate your help as well, RLGL. Thank you all so much! Now I know I need to be extra diligent when installing new versions to always uninstall the old.

Also might I add: you guys are impressive with the response times and detailed guidance. I really, really appreciate it!

Thanks. At the moment the backlog in support isn’t anywhere near what it was a few weeks ago. You would not have been happy with the response time then!

I’m in QA now, but still am in contact with my ex-colleagues in support. I will let them know what the issue turned out to be.

1 Like

Glad you got that sorted.

It’s not just a reinstall. It’s making sure that SketchUp and LayOut are correctly installed. If you didn’t use run as administrator when you installed, it would still be a good idea to do that.

Great idea, thanks!