Layout not importing drawings correctly

I don’t know if anyone has seen this, I am sending a file with multiple scenes to layout and the rendered size is clipping the original view. Further, the arrows and dimension labels is layout are nowhere near as neat as in the sketchup view.

Version Info:
Sketchup Pro Version: 21.1.298 (2021)
Layout Version: 21.1.298 (2021)
Cumputer: Apple Mac (MacOS Big Sur 11.5.1)

Steps to reproduce:

  1. Open the sketchup file and send to layout
  2. Select A3 paper size
  3. Note crappy look.

I have tried scaling/vector/raster settings to no avail. Would have thought something so simple would have just worked.

I have attached the skp file (I have two two screen shots of what is happening but it only allows for one attachment, one from sketchup and the second from layout).

Any ideas?

Ta,

Martin.

Upper Hinge Slide Base.skp (89.6 KB)

The screen shot of the sketchup file attached.

The screen shot of the layout file once the SKP file is sent to layout.

Looks to me like it’s done what it is supposed to do. The size and aspect ratio of the viewport are determined by the paper size you selected when you started the LO project. Resize the viewport by dragging the edges after you set the scale in the SketchUp Model panel.

Take a look at this LO file as an example. I replaced the dimensions in SU with ones in LO trying to avoid conflicting dimensions. I also put the top and edge views in the same scene and viewport. Makes it easier to manage.

Upper Hinge Slide Base.layout (139.7 KB)

1 Like

FWIW, if your SketchUp model window matched the aspect ratio of the paper you chose, the model would be displayed entirely within the viewport from the beginning. Since your model window doesn’t match, you have to do some adjustment to the edges of the viewport. Personally I would just make the adjustment to the viewport once it’s in LO.

Here I’ve match the SU viewport aspect ratio to the A3 paper.
view

I did try the scale thing but it seems not to do anything, refer the first image taken immediately after I sent the file to layout.

Then the second after I only changed the scale. Two things did happen, first the “Preserve scale on resize” was automatically checked and secondly I wind up with an explanation point on my imported scene (which I have no idea what it is).

(Refer next post as I cannot upload more than one image per post).

The Exclamation point symbol indicates that the viewport needs to be rendered. You have Auto render turned off so it won’t do that until you click the Render button or tick the Auto check box.
Screenshot - 8_10_2021 , 6_49_54 PM

1 Like

Ah, I kept clicking render and nothing happened, clicking auto has it working like a charm.

I also had a look at your layout file you sent, I like it, much better way of dimensioning, looks great too. Is there any way to specify radius/diameters?

Thanks again,

Martin.

There currently isn’t a radius dimensioning tool. I generally use a label and manually enter the radius.

Seems strange to see it missing given the rest of dimensioning exists in sketchup, perhaps a feature request? Anyways, thanks for your help, I really appreciate your time.

Martin.

It’s on their list. Hopefully one of these days we’ll see it.

You’re welcome.