Layout not automatically rendering model updates

I have Sketchup pro 2023 and Layout 2023. After I make a change in my model in Sketchup and save it, I then go to Layout click “File” , “Document Set Up”, and then “References”, select anything in red and then click “Update”. Then a yellow triangle with an exclimation mark appears on every page in my layout document and I have to right click in the margin and then click “render”. This has to be done every for every page in the document even though the change was specifice to only one page and its viewport. In Layout 2022 the updates happened automatically and I didnt have to manually “render” each page to update my drawings. What is happening now is a real time suck.

Select a viewport on the page, go to the SketchUp Model panel in the tray and tick the box for Auto Render.

Keep in mind that any scene properties you’ve changed in LayOut (indicated by a dark gray background and Reset button. In the SketchUp Model panel) will not be updated when the viewport is rendered unless you click on the Reset button to remove your overrides.

Dave,

Thanks, that did the trick!

1 Like

hi Dave. I encountered this same issue - I selected multiple viewports on a page, clicked Render to update them, then checked the Auto box, thinking that this would ‘reset’ them to auto-render in the future. A small box to the right of the Vector/Raster/Hybrid drop-down opens, showing a green progress animation (for lack of a better term) - then Layout crashes. This has happened multiple times. I’ve been careful about saving my work, so no losses there, but I’m puzzled by the repeated failure. Any suggestions?

I don’t know for sure what would be causing it but it could be that you are overloading the integrated GPU and it doesn’t have enough resources to handle rendering all the viewports.

Turning on Auto render can be done by selecting just one viewport. You don’t need to select a bunch of them. One thing you might try is leaving Auto Render disabled and then render viewports one at a time.

What’s in the SketchUp model? Perhaps there’s some simplification that can be done so that there’s less linework for Vector rendering?

Which version of SketchUp are you using now?

I just tried selecting only one viewport and going to auto - same result. Am using Pro 2022. Rendering viewports one at a time works - but is tedious. This just started happening in the past week after I added a new sheet to my Layout set with a reference to a different SKP file - but I have numerous file references in this set and it has all worked fine up to now. The Layout file is not terribly large - under 6MB - but the SKP model has ballooned to about 60MB.

The number of viewports you select prior to enabling Auto Render is immaterial. Selecting one or all amounts to the same thing as far as the tick box is concerned.

Since this just started happening I guess the place to start digging is with the latest SKP file added. If you want me to take a look at LO file I will. I’m at a FIRST Robotics meeting but when I get home I’ll look. Upload the file to Dropbox and share the link. Send it to me in a private message if you don’t want to make it public.

Thanks for the offer, I’ll send you a link in a private message. My Layout set has 19 sheets; got through them all, re-rendering all viewports, correcting various dimensions and text leaders that got whacked out somehow, went back to the first sheet - and all viewports need to be re-rendered again. Very odd - hope you can shed some light on it.