LayOut 2022 will not render views in drawing. File crash

I Recently updated from version 2021 to 2022. I now have issues with all views in my drawing not rendering. All show a ! symbol on them and need to be fixed.

If I try and click out side the page and update each page to render the page, file crashes.
If i try and set to Auto render in the viewport, file crashes.

Only way i can render each view is one at a time.

If i try and update model reference all the views on every page show ! symbol again and need to be rendered one at a time.
Most of my views are set to Vector for improved line quality.
In the past (2021 version)I could check the Auto box in the Viewport and all would be fine…

I have set up model scenes which drive the views, but sometimes I had to adjust tags, style or camera in some of the view to get things to look right.

I have also noticed every time I open the drawing it says the model is out of date, so once I update all the views will show the ! symbol again and back to fixing.

Not sure how to fix this, very time consuming. Is this an issue caused by how i set up each view, or computer can not handle the task or 2022 version bug?

Drawing files size is up to 61MB.

Any thoughts or suggestions welcome.

Share the LO file so we can see what you’ve got going on. 61Mb is too large to upload directly but you can upload to Drop Box or similar and share the link.

How about OneDrive will that work? Do you need the 3d file as well as the 2D?

That would work. No need for the .skp file.

Got the file. Since it contains sensitive info you might want to lock it up and remove the link now. I’ll take a look at the file and come back.

I removed it. Thanks for looking.

1 Like

In your screen shot of the SketchUp Model panel you have Auto turned off so the viewports wouldn’t render automatically. Evidently you’ve turned that on before uploading the LayOut that I have.

I’m not having any issues with LayOut crashing when rendering a viewport or anything else. It is a tiny bit slow with the original file but LayOut doesn’t quit. I wonder if this might be a graphics card issue. Could be that 965M is being taxed a bit. Are you working on battery or do you have AC mains power connected?

I notice every viewport has had the Camera properties modified (dark gray background and Reset button). There should be no need to do that in any of the viewports in your project. It’s not a good idea to do so, either. It overrides the Camera properties for the scenes in your SketchUp model which means that edits to those properties in the model will not be displayed in LayOut unless you reset the camera. Resetting the Camera properties will bugger up the dimensions and labels attached to the model. Like this or worse:

It would be easier and safer to use scenes in SketchUp that show the elevations. You have scenes in the SketchUp model file already that show the elevations.

FWIW I looked at the embedded model. I did find some incorrect tag usage. This isn’t likely to make LayOut crash but it will cause other problems.
Screenshot - 4_12_2022 , 2_23_58 PM

There’s also quite a lot of unused stuff in the model. Purging reduced the SketchUp file size by 78% and the LayOut file size by over 54%.
Screenshot - 4_12_2022 , 2_24_26 PM

It also looks like you’ve copied some images from somewhere and pasted them into LayOut; the last few that show as Clipboard references.
Screenshot - 4_12_2022 , 2_47_29 PM
Although this works it’s a good idea to keep in mind that you have no external reference for the files to fall back on if you need them. Better to save the images into the client project folder with the SketchUp file and other references and then insert them into LO. That ensures you have your backside covered.

When you experience LayOut “crashing”, does it just quit? Give you a Bug Splat? Or does it show “Not Responding” up at the top. If the latter, that’s not a crash. It’s LayOut’s way of telling you it’s busy doing something and it won’t take further input until it’s done.

I will share the purged LO file with you if you want although I reset the Camera properties on that viewport so it needs replacing.

I think you are right on this, as i have a loptop with better graphics(Intel(R)UHD Graphics) and i’m not seeing the same issues. I always work plugged in. I will respond to your other thoughts and questions. I’m new to LO so best practices you mentioned should help a lot. On the first page of the drawing there is contact info. if you want to send a link to the files. (not sure if this is ok or not) More in a bit.

It just quits, as in have to reopen the file. If I render one at a time not an issue.

That does imply the graphics card is rolling over.

I’ll send you the file when I get back to my computer.

in general sounds like some clean up work and best practices will help a lot not only on the modeling side but drawing as well.

Great advice will fix this. So drive the drawing through scenes in the model is best practices. So better to have many scenes in the model then modify the drawing viewport.

1 Like

Yes. I think that is an accurate assessment.

Like with many things, there are practices on the front end that can make things easier or harder down the road.

You don’t necessarily need many scenes in SketchUp. Often you can make one scene do double or triple duty with strategic use of tag visibility and cropping of viewports. Note you can crop viewports by dragging their edges.

Hi Dave, what about camera views, wouldn’t i need a camera view for each view (right, left, front, plan, iso, etc.) in the .skp file to drive this if i’m not going to change views in the LO viewport as shown below?

From what i understand, skp file should drive, views, tags, Styles, etc. in the drawing. If this is the case that would be a lot of scenes or maybe i’m missing something.

Yes. That’s the point. Make scenes with Camera settings in the SketchUp file to use for the viewports in LayOut.

Yes. The scenes drive the views in LayOut but it doesn’t necessarily require a lot of scenes.

Modifying tag visibility and styles in LayOut doesn’t cause the problems you get by modifying the camera properties. Don’t modify the Camera properties in LayOut if you want to be able to manage those properties in SketchUp. If you do modify the Camera properties in LayOut, be prepared for the sort of thing I showed with the dimensions.

ok got it now getting the best practices.
Now i need to know how to reduce the file sizes, i have removed all that i can but i’m not seeing much of a files size change ( still at 61MB) any thoughts? I imported some models and wondering if this may have caused some of the issues over all and with file size bump.

Are you purging the file after deleting things. There are purge unused options on the components and material trays and a some others, or there is a main Purge unused button at Window/Model Info/Statistics.
When you delete things from the model space some of them are still stored in the model for future use, so you need to purge them to reduce the file size. This can be very helpful as a component once deleted can still be brought into the model from the ‘In Model’ section of the component browser, but it can also fill your model with lots of junk if you keep trying things out and deleting them. This goes for materials, styles, tags etc. So, purging is an important part of the workflow, but you also need to understand what you are purging or you may lose things you want. I’ve seen people set up an elaborate tree of tags only to lose them all in a purge because they were currently being unused.

1 Like