Layout will not update SketchUp viewports

All of my Layout documents are refusing to update from the SketchUp model. When trying to update a viewport either manually on a sheet, or when opening a file that then updates from an amended SketchUp model, the viewport windows all get tagged with a yellow warning triangle - the same triangle that locked viewports have when their source model has been updated.

I have the same problem on all of the drawings. I have tried to create new files from SketchUp and Layout but the same happens. On importing a new viewport / model view the new window appears blank with the appended yellow triangle.

I have reloaded SketchUp Pro 2021 from fresh download but the same problem persists.

I have restarted the computer, cleared all the caches, logged out fo Trimble then back in again. All to no avail. The problem is still there.

As professional architects we rely on SketchUp and Layout to produce drawings. If this problem isn’t fixed soon we will need to look elsewhere as we cannot afford to be without the ability to produce drawings ; this is the end product of our entire business.

Help

Have you checked this dialog box. Does it report any errors in linkages?

In addition to Simon’s question, does the References list show .skp files as embedded?

And is Auto render enabled?

The document dialog box looks normal. No errors, nothing embedded, status all current. Remember this isn’t just one affected file, its literally dozens. It looks like Layout thinks every window/viewport is locked even though they aren’t.

It would be interesting to have a look at one of your LayOut files. Any chance you can share one that is problematic?

Looks like you might have found the issue. For some reason auto-render was not enabled, despite the fact that it always was previously. I have switched on auto and now the windows do appear to update. I have tried half a dozen files and now they all work. Question now of course is why did Layout switch off auto-rendering because I most certainly did not. I will be back in touch if the problem re-occurs but for the time being at least this does appear to have fixed things. Thank for the help.

Not sure why it would have been turned off. Not sure that LayOut can even do it but if it is turned off in your template it would be off in any files created in that template. It would be a good idea to check that.

I appreciate the advice, but this is particularly weird because I am the only person who uses this programme and I certainly did not switch off auto rendering. It must have been switched on before because this problem has only just arisen. Only possible yet very implausible possibility is that the cursor was just in the right place when one of our cats stood on the mouse. (sorry about the cat v mouse pun). Anyway for now looks like this is sorted. So thanks once agin for the help.

LOL.

I consider cats outside forces. Seems like a reasonable cause in this case. Keep an eye on the cat and LayOut.

I just went through this very problem last night with 2020. Eventually I had to:

  1. Tell it to relink to the wrong file (for me an out of date version), and then
  2. Tell it to relink back to the right one

And that seemed to set it straight again.

Was the file embedded before you did all this?

It had been working as expected for a while, ie making revisions in SU, saving, going to LO and updating the link. Then suddenly it wasn’t working any more.

It looks like there’s some cache scheme going on, and I feel like it needs some need to clear the cache and do it over again.

1 Like

Yes, they can cause catastrophes (but mainly in Greece).

Where is this setting? Do you mean the “Check references when loading this document” checkbox?

No. In the SketchUp Model panel.
Screenshot - 10_22_2021 , 1_11_30 PM

Doh! It’s right there, even I looked at that pane.

1 Like

Was it next to the keys?

1 Like

I had similar problems yesterday. Using my 2019 Pro license with Layout. I wanted to change the line thickness (I think) of the viewport, so I deactivate the “auto render”, otherwise I the vector pt menu is greyed out.Tried changing the pt thickness and hit “render” manually - nothing happened. Thereafter, I couldn’t change from vector to raster or hybrid neither could I activate “auto” render again. I don’t think I restarted Layout either. I don’t have LO open in front of me atm but I think I right-clicked the viewport, which had a render menu option. Then the navigation menu items became functional again, so I just left it on auto, even though I don’t like the thickness.
A day before that I also had a scenario where I had saved the SU file and updated the reference list in LO BUT the viewport didn’t update. I fiddled a bit with auto render then as well and nothing worked to update the viewport. I cannot recall now what I did but LO eventually updated the viewport. I wonder if there is rendering lag and one simply needs to wait for 5min for LO to figure out what it wants to do. Not sure, it but it is a little frustrating.