Layout lagging after Mojave update

lag

#1

Layout is lagging in zoming and really all operations on my MacPro. Sketchup is fine. I did update a couple of days ago to Mojave.

Anyone updating to Mojave having this issue?


#2

I’ll second that, MacPro too and its pretty useless when referencing a SU model. Seems to perform better when drawing directly in LO. Have checked the same file on and High Sierra machine and it works OK.

Anyone know a work around, or do I need to downgrade to High Sierra?


#3

There has been some testing done with SU/LO2018 on Mojave but no updates made. This late in the year, I wouldn’t expect to see any updates until SU/LO2019. Historically new major releases come around the end of November. If Mojave is causing problems, it seems like a good idea to roll back the OS for now.


#4

I have resolved the lag issue. I changed the Thunderbolt monitor connection to bus 1 and all is well. There are three buses, 0 through 2.

Thanks.


#5

That’s a good thing to know for others who might have the same issue. Thank you for posting that.

@Thomasjenk, do you think this would help you?


#6

@DaveR Afraid not. I was running on bus 0 but changing to 1 or 2 makes no real difference


#7

Hi

Yes, same issue here on new iMac, with Mojave and Layout.

From the comments above, I’m thinking its Mojave as it works fine on my MacBook Pro with High Sierra.

Mke


#8

I tried my MacBook Pro with Sierra and it too works OK.


#9

I have about run out of love for Mac. I need performance to produce construction documents in Layout. This lag in Layout is killing me.

Apple with a trillion dollars in cash can’t produce a high-end 3D machine?

Anyone experiencing the Layout lag in Windows?


#10

I’ve been using LayOut pretty heavily for a long time on PCs and I haven’t run into any huge lags.


#11

It’s sad, but there’s a lot of evidence that Apple has come to view desktop and laptop computers as a fading market that won’t yield a good return on further investment or innovation. They aren’t quite killing them off, but kind of letting them die a slow painful death.


#12

You are right. I thought a few keys of my keyboard were out (turns out Mojave reset an Accessibility setting) and I went to the local Apple store to purchase a new keyboard.

On the center tables, there was a handful of notebooks on display and 95% +/- was iPads, iPhones and Apple watches.

Apple is a handheld device company.


#13

I hope to god Layout is improved in V19. Brand New iMac, Layout dies under Mojave, completely unusable.


#14

Interesting, but differences: @tvallee is a Mac Pro, which he fixed because changed his Thunderbolt Monitor ports. @Thomasjenk has a Mac Pro as well, but port change didn’t help. @MichaelSiggers, you have an iMac, and we haven’t been able to repro. But what else do you 3 have in common? Mojave and ? Dark mode? Space Navigator? Some Metal setting, which I don’t know of? I’m stumped.


#15

Good Morning @Barry

Mine is a standard iMac, 2017 model running Mojave 10.14.1. Factory installed and updated to the latest version.

I do have Dark Mode enabled and will try reverting to normal mode and see what happens.

I am using the standard Apple Magic Mouse 2 and standard Keyboard.

As far as I’m aware, there are no options at all to change anything to do with Metal, or the GPU or GPU Drivers. Or Open GL/CL etc. There is simply no option for it in any setting, anywhere. It is an AMD GPU which is different from my old iMac.

Checking in previous specs, my old iMac, a late 2013 model, was the last one to use NVidia GPU.

The only thing I have plugged into mine is a LaCie External Drive for Time Machine.

Software wise, I only have Sketchup Pro 2018 installed, Microsoft Office, and Photoshop, alongside the preinstalled software.

Mike


#16

Changed to Normal Mode, and not Dark Mode. It makes no difference.

Here is, hopefully, a short screen movie showing the zoom in Layout. This is constant gentle scrolling on the mouse too.

It baffles me how I can use Photoshop and open and work on an image which is nearly 1GB in size, with multiple layers, with absolutely no problems, but a 5.9MB Layout file is a killer.

Mike


#17

While changing to another Thunderbolt port worked briefly, I am back to the same lag.

I use a MacPro late 2013 / 3.5 GHz 6-Core Intel Xeon E5 / 32 GB 1866 MHz DDR3 / AMD FirePro D700 6144 MB / Magic Mouse 2 and Magic Keyboard / LG monitor

I have never had this issue and I am on my 4th machine running Sketchup. First 2 ZPZCs and last two Mac Pros.

I will have to do something soon. Can’t produce CDs with this lag. Maybe this is the change back to PCs.


#18

Here’s my latest reading on mouse issues in Mojave:

In a separate reading in which I DON’T think this would affect, someone mentioned that Mojave has default settings that disallow some automation to control mouse or keyboard, and you have to go into System Preferences for Universal Access and allow keyboard and mouse access.

We’ll keep searching for solutions.


#19

I don’t see anything that addresses the issue. Layout remains unusable.

Am I sing something?


#20

Must confess, I never had any problems with the mouse, as that worked fine.

In fact today, I’ve just had a Logitech MX Master 2S delivered, (should have got it ages ago as it’s way better and more comfortable than the Apple Magic Mouse), and the zoom issue is the same in Layout.