Macbook Air M1 vs Macbook Pro i7 - both have 16 GB RAM

Showing the lag in Layout on both computers. This Layout file has large appliances slowing it down.

I’m wondering if anyone out there can download the file and run it without any lag? Is this a thing that’s possible on any computer?

Or is this simply as fast as this software can go?

Thanks!

Berenstain Kitchen.layout (5.2 MB)

1 Like

Video showing lag here

1 Like

This is what I see when panning on my seven year old computer. I expect what you are seeing has to do with the graphics cards in your computers.
pan

I had a look at some of the appliances in the SketchUp model. They could be simplified to reduce their load on the model. Even more so for the plumbing fixtures. Nearly 17,000 entities for just the end of the faucet seems excessive for no more than it contributes to the overall model.
Screenshot - 7_16_2021 , 8_16_53 AM

I unhid the edges in the range so it doesn’t look like a ghost.


After saving the change in the SketchUp model it took LO less than 4 seconds to render the viewport.

I also purged unused stuff from the SketchUp model.
Screenshot - 7_16_2021 , 8_10_09 AM

3 Likes

I have no issue navigating it on my ancient win 7 laptop.

2 Likes

Dave may have made things be smoother for you, but on my M1 iMac without making any changes to the model, scrolling becomes a lot smoother when I set the SketchUp Model to be Raster instead of Vector.

2 Likes

I’m not near as thorough as Dave is, just opened the file and honestly didn’t see any changes in how Layout operates compared to any of my files. I’m on a 2021 27" iMac so it brings a bit more power to the table than your MacBook Pros. I honestly didn’t see great performance on my 2019 MacBook Pro without having a egpu connected.

Those appliances you chose are models I have used before and seldom seen issues with them. I would say that I have seen more slow down with the metal mesh door panels before. Lots of data in those and the rendering can take longer because of how close all the lines are to each other…at least that’s my low-knowledge take on the issue. When my system slows down because of those I will move to a 2D grid just to communicate the mesh in the elevation.

Also, a good tip to keep in mind in Layout: at the very least tag all your parts and turn off all tags that aren’t in the given viewport. The less a given viewport has to “think” about the less lag you will get with that viewport. I noticed in your sketchup model that you have parts sitting around the model and the island sitting above the main kitchen. If you have these on tags and turn them off, Layout doesn’t have to worry about them.

2 Likes

I think what I’m essentially asking has only to do with hardware. I realize there are a number of things that could be done to make the model run faster, but if we are all opening the same file, in the same state, on different machines and getting different results when navigating or trying to pull dimensions then the question is: what is causing that difference?

Is it the graphics card, RAM, processor (shouldn’t be that with the M1 in a brand new Macbook Air, right?), etc?

WHAT CAN I BUY TO MAKE LAYOUT RUN SMOOTHLY???

2 Likes

Mostly graphics card capability.

I only brought up the things you could do to improve the model and performance since you most likely won’t be changing the graphics card in your MacBook Pro or Air.

I’m returning the Macbook Air

By F1-car?

You’re getting the lag too! What computer are you using?

This was on a Macbook Pro
Schermafbeelding 2021-07-16 om 17.12.44
I had a video of Max Verstappen on the background running, what was the noise in your video?

1 Like

Very loud traffic noise coming in through the window, and also the door was open to general shop noises.

1 Like

More or less I have the exact same issue using sketchup layout.
I have used it for years and find the 2021 version so slow that I can not continue to use it. I have a macbook pro2.2 GHZ quad core 16 GB with Intel Iris Pro 1536 MB graphics card. Do I have the ability to save down files and go back to an earlier version, which worked much better? (on the same computer).
The problem really is when I zoom in on a detail to work close in…it freezes up most of the time.

1 Like

I wasnt getting any slowness at all.
Then I made 5 copies of the plan on the page, and LayOut just started to slow down a little.
After 10 copies it starts to look like the sort of lag you are seeing.

So it’s not entirely the fault of the geometry.

During the most LayOut operations, including pan/zoom operations, the video card is not really active. LayOut barely uses the Graphics card and instead uses the CPU for it’s rendering (especially in Vector mode).

So I dont think it’s the graphics card.

RAM also doesn’t really have any impact here.

What might be happening is there is some internal competition over resources being shared between CPU RAM and GPU functions.

It’s worth noting the speed difference of CPUs can be large. For example your CPU might be 2.2ghz quad core. But that’s like saying “my car has 2 litres and four cylinders” …it doesn’t really reflect the performance. A 2016 CPU compared to a 2021 CPU could be like comparing a 1978 Ford Pinto (Cortina) to a 2021 Honda Civic Type R. (eg, 3x the performance).

So which model CPU is it?

(and note that the M1 is a unique type of processor and may not be directly comparable to the others).

Finally, check your power settings and screen resolutions. Laptops’ efficiency modes will kill performance. Also, running a high res monitor screen may impact GPU in some scenarios - canyou try setting resolution to 1080p? At least that may help identify the GPU as an issue.

What hardware are you using? Graphics card, CPU, RAM, etc?

What hardware are you using? Graphics card, CPU, RAM, etc?

I’m on Windows 10 so it’s not a direct comparison.

My PC is:
AMD 5600X
Nvidia RTX2080
16GB RAM
4k monitor.

I also tried it on my windows laptop which is using an i7 8750H (a bit older) and a GTX1070-maxQ. On that laptop, the Layout file is very fluid but gets a bit slow after 4 copies of your geometry. Still very useable, just not as fluid.

This is all with 4k monitor, object Snapping turned ON, etc…(default setup). And Im running stuff in the background, 2 screens set up, etc…very typical of daily use.

>98% of the LayOut processing load is on the CPU
And >98% of that is using only 1 core.

So the specific single-Core speed (not GHz, but actual calulating power) is the critical factor.
You can’t just rush to CPU Charts and pick the top of the list since CPU’s of different generations differ in their optimisations; some generations make a leap forward in some types of calculations. There are also differences in CPU memory handling/cache, etc, which could be affecting LayOut. And then there’s the way that the CPU interfaces with other components via the motherboard chipset. The graphics card can’t be entirely ruled out because it does have some impact on how anything is displayed on your m onitor - if your other programs are also lagging then maybe you have an issue.
Can you run any sort of benchtest software, eg 3d Mark, (i dont know what Macs have available) to isolate your hardware bottlenecks?

It’s difficult to test without a benchmark, but your file seems to be a good thing to use for a Benchmark.
Adding geometry to a page and seeing how long it takes (how many copies of said geometry) before LayOut starts to visibly lag, is probably the best we can aim for.
Render speed via hybrid or vector rendering of a complex file would also be a good test.

Also, as I’ve mentioned in other threads, LayOut and SKP use a lot of saving/syncing which is hard-drive based, so overall layout performance can benefit from the fastest possible hard drive)

1 Like

Hi Dave. I have a problem when I do this that hasn’t been addressed in that some viewports render in different resolutions on raster mode. See attached movie. Screen Recording 2021-07-08 at 4.53.18 pm.mov - Google Drive

People don’t normally call me Dave. And, there is no technique in SketchUp that is called the Colin Method.

That aside, I’m not sure why some viewports look low quality. There is an oddity in LayOut where vectors are drawn at a different size to raster, and how different they are depends on the distance of the geometry from the origin. If some things are far away, that could be the significant difference.

Unless you are doing screenshots, you should set the display resolution to medium or low. With it set to low you may be able to stay in vector, and get ok performance. Another option is to tolerate working in raster so you can work quicker, then switch to vector if you need to do screenshots or export images.

I’m curious, you have the same accent as me. Are you up very late, or you also live in the US?