Layout keeps resetting style and font preferences

I have SU/Layout 2021 and am having trouble with Layout remembering my font size selections, stroke widths, fills, etc.

I set my preferences at the start of each project, and as soon as a tool is selected, they revert to some preset I can’t figure out how to change it. For example, I have Fill turned off. But no matter what all shapes I draw are filled. I have to manually go back, select it, and turn fill off. Another example, I select my arrowheads to size 3, but LO draws them at size 5, and I have to manually go back and select them and change them back to 3. Another example, I set my type size to 14, but as soon as I start typing, it changes to 12. I have to manually go back and select it and change it to 12.

I am losing a ton of time having to do everything twice, and having to do this for every single action. I don’t remember it being this way in earlier versions. I just set it once and was on my way. Something changed and it’s not for the bettter.

Is anyone else having this problem or knows how to resolve this? Much appreciated. Thanks.

You need to make those settings while the appropriate tool is selected. If you make adjustments without select the tool first, they have nothing to be applied to.

If you are making the same settings for each project, why not create a template of your own to use which contains those settings?

I do set the settings while the tool is selected. Then as soon as I use the tool, it pops back to some default settings.

I set it at the beginning of the project, and then I set it when I select the tool, and then I have to set it again after I use the tool.

Hmmm… What happens if you create a text entity, change the settings for that, get the Text tool again, press S and sample that modified text. Do the settings then “take”?

Note that Text, Labels, and Dimensions can use different fonts/sizes so making a setting for label text won’t affect dimensions or non-label text.

Have you tried creating your own template with the text already setup?

The settings so not take. They keep popping back. It’s pretty remarkable.

I’m not a template user, so I can’t speak to that.

My hunch is I may have some corrupted preferences. My next move is to trash my preferences and do a clean install. I just thought I would reach out to the community to see if anyone else was experiencing the issue.

Thanks for your suggestions.

I haven’t seen what you report before. Maybe the preferences are corrupted.

When you start any LayOut project you are starting from a template that has a variety of settings including paper size, Shape Style settings, fonts, layers, etc. If every time you start a new file you have to change these settings to match what you want, you should be making a template with those settings. Then you don’t need to waste time making those settings for every project.

Sue_Storm, try this: Make a text or label or dimension with the characteristics you wish to keep. Then sample it with the dropper. The dropper will change to a bucket. Move the bucket back to the dimension (or whatever) icon in the tool bar. The bucket will change to an arrow, but click on the icon anyway. This will set the default for all future uses of that icon until you repeat the process with new characteristics. The learning curve continues.You can use this to set up your templates. I think I learned this one from one of Matt Donley’s tutorials.

2 Likes

That worked!! Thank you Gary!

Keep in mind that while it works for your current project, if you don’t set up your own template(s) with the desired style and font preferences, you’ll have to make the settings again every time you start with one of the program-supplied templates.

Okay. Thanks Dave.