Layout just suddenly slowed down! ISO TIPS, urgently, please!

Any quick tips for getting Layout to play nicely?

I’m adding drawing notes to a presentation set that’s due today and the program suddenly just came to a crawl. Gah! I’ve had historic issues with the speed of layout and it’s been inconsistent (fine sometimes, miserable slow other times). Today after working well enough all morning, now the simple act of zooming/panning sets off the dreaded spinning beach ball and delays all operations.
I have the viewports set to Raster, I’ve purged the file, and the Display Resolution is set to low.

Any other tips?

Computer stats in case it’s relevant :
MacBook Pro (16-inch, 2019)
Processor : 2.6 GHz 6-Core Intel Core i7
Memory : 16 GB 2667 MHz DDR4
Graphics : AMD Radeon Pro 5300M 4 GB / Intel UHD Graphics 630 1536 MB


  • Marta

Is your profile correct with SketchUp/LayOut version and operating system?

Simple thing to try is to save and close LayOut. Then totally power off and reboot your computer.

Hi Dave,
Thanks for the reply. I’ve rebooted numerous times to no benefit.

What do you mean about my profile being “correct”? I’m on LO Version 22.0.315. Haven’t yet upgraded to the latest update release but I keep current.

Screenshot - 4_21_2022 , 12_46_23 PM

Okay, looks like I need to update something somewhere… Tips on how to do that?

Click on the M in the green circle in the upper right corner of the Forum screen. Click on the person icon. Then on Preferences. Should be self-explanatory from there.

How large is your LayOut file?

Thanks for this Dave, I’ll follow the guidance you offered.
In the meantime - LO file size is 103 MB.

Have you purged the LayOut file?

Maybe you could share it via DropBox?

How big is your model and LayOut file? How many edges and faces in SketchUp (components included)? How much RAM is your Mac using when your LayOut file is open?

I would perhaps ban the use of 3D Warehouse. When you have to make your entourage components yourself, you pay attention to their complexity.

1 Like

Thanks @DaveR and @Anssi,

  • Yes, I’ve purged the LO file and the SU File as well.
  • SU Model is 75 MB
  • LO File is 103 MB
  • Edges - 1,500,554
  • Faces - 701,849
  • Memory being used with LO and other programs open : 12.6 G

Does any of this inform why LO is slow as molasses?

@DaveR - I’m curious - How does having updated those fields in my profile make a difference for LO’s performance?

No, obviously not. But using that information is how helpers craft answers that are relevant to the person who posted. Someone using Layout 21 on a Windows platform using an integrated graphics card of a certain make might receive completely different advice from you. For instance the graphics card you are using (Layout should automatically use your high end graphics card which is the AMD, not the Intel) is actually much more competent than the one you have listed in your profile so we can rule that out and not waste time.

Are you sure (trying to be helpful here) that all viewports are set to raster? Try turning auto render off and see if performance improves. Layout occasionally bogs for me, but a restart of the computer usually fixes it unless the file is enormous. Have you opened a smaller layout file to check if it’s specific to that file or program wide. Are you adding a graphics card heavy load to your computer ins some other way outside layout? For instance both SketchUp and Layout bog significantly when i’m simultaneously running Zoom. Are any of your reference files or the Layout file itself working off a cloud drive?

Thank you @endlessfix . Now I understand why the profile update is important.
I’ve been keeping Auto-Render off, so that’s not the culprit. I’ll double check and ensure all viewports are set to raster, though I am nearly certain they are, and the simple act of zooming out and selecting the viewports take a painful amount of minutes.
I’ll confess - the layout and sketchup files are on iCloud - always have been in the years I’ve been using Trimble products. I understand the two programs talk to one another and transfer data to/from the cloud in that process but, again, I’ve always saved the files on the cloud and the sluggishness of the past 2 weeks eclipses anything I"ve encountered in the past.
Again, thank you.

How do you/the masses save large SU and LO files? Locally?

1 Like

Running files on the cloud is a risky practice that is known to cause corrupt files. It’s a roll of the dice but if autosave and the cloud system both try to update/sync the same file simultaneously we often see corrupted files that cannot be recovered. Best practice for cloud usage is to save and work the files locally, then sync to the cloud manually once work is done, say at the close of each day.

Woking off the cloud also puts you entirely a the mercy of your internet connection. If it is unstable, slow or bandwidth is being shared by other uses on your computer then your workflow will suffer. I would try downloading your Layout file and all it’s references to your local drive and loading the layout file from there, turn off your internet connection for the test and see how Layout runs.

Got it. Thanks for this. Gonna give it a try right now. Appreciate your feedback @endlessfix !

1 Like

:+1: It could still be something else but this test will rule out, weird firewall or permission issues, or security software interference that could be part of the internet connection problem. Turning your internet connection off is just to make absolutely sure you are running everything locally.

If this all started two weeks ago, what changed then? Or did the file get significantly bigger then?

It doesn’t. That information helps us help you, though.

Thanks @DaveR

Thanks @endlessfix . I’ll follow your guidance. Truly appreciated.
I can’t think of any change that would have caused this abrupt slowdown. It really caught me off guard. Hopeful your advice at least gets this drawing set out today!
Again. thank you!

I’m not going to be able to guide like my collegues here. But having had all the same problems and the same platform, one of the things that helped me was assigning zoom to page to a keyboard shortcut or a mouse button. The scrolling zoom has never gotten better for me. Although zoom-in is a minor pain still, when I need to zoom out, i hit that zoom to page button and instant success with no slow down.