Layout issue loading

This has been discussed before but I have taken all the steps advised in the previous conversation which did not solve the issue.

So up until yesterday I was able to directly load model image into layout. Today I cannot!
I have:
saved the model before sending it to layout
Checked my version and repaired it
Run as administrator

I have several versions of SU on my computer 2016, 2017 ,2018 (being the one I think I use) and 2019. Is it best to delete previous versions? Im wondering whether its confusing SU and opening the wrong layout programme? Does SU have the same issue as CAD when it wont open documents made by an earlier version. I ask this as I have several models from different versions which I must be able to access if i delete the earlier versions of SU.
Thanks for your help in advance

No. An older version of LayOut won’t insert a SketchUp model made in a newer version. Make sure of the SketchUp version you’ve been working in and then open that version of LayOut. Can you insert the SketchUp file from LayOut’s File>Insert?

Hi there
no, sadly I cant insert previous layouts into LAYOUT page either. Can I ask how do I open the correct layout version? Is the most recent one have the (*layout) file name? Underneath this option are all the dated earlier versions.
thanks Jo

I didn’t ask you to insert a LayOut file into another LayOut file.

If you have their icons on your desktop it should be fairly easy to figure out which version is which. This is what they look like on my desktop.
Screenshot - 6_10_2020 , 6_20_59 AM

Alternatively you could click on the Start button in the lower left corner and scroll down to the SketchUp entries. Then select the correct one.
Screenshot - 6_10_2020 , 6_23_00 AM

Ive tried this and it still wont work.
Can I ask wqhy do you keep all the older versions of SU- wont this clog up the computer space etc?

I keep the more modern old ones because I am frequently teaching people who refuse to update to the current version. For my own work I use the current version. The ancient V3.1 was installed only because I found the disk and was curious how well it would work on Windows 10. (It works fine.) They do take up some space on my C drive but it hasn’t been a problem.

Why do keep all those versions and why do you use SU2018 when you have SU2019?

Back to your issue. Can you open your file in SU2019 and send it to LayOut?

Yup, I misread what you said. I can open a SU file from layout file insert but it comes in flat in 2d —i think like a layout image! could be wrong here

I dont have a licence for 19, only 18 i believe? so i deleted it.

That’s what it is supposed to do. LayOut is for doing documentation and so you will see the scenes you’ve created in your SketchUp model as flat images in the viewports.

If your Maintenance and Support was up to date, you should have gotten the license for SU2019. You could check here:

Yes i get that but… I want to manipulate my model in SU then send that image to layout.

If i bring the model in as suggested it wont be the image im attempting to capture

You need to create scenes in SketchUp that show the model the way you want it to appear in LayOut. Then use those scenes for the viewports in LayOut.

sorry , your being very patient. This is what I am trying to do, send the scene from SU across to layout. I have done this successfully for years. For some reason it will no longer do it.

Do you already have a viewport showing the model in the LayOut document? Or is that you can’t even start a new LayOut document with Send to LayOut?

I have never set up VP in SU only CAD. Previously as SU Help explains, I just press the layout button and the image goes over automatically, exactly as shown in SU.

obviously after saving and updating scene

but now nothing come across

Try this: Quit both SketchUp and LayOut so they are totally closed. Download the 2018 installer from and once it is downloaded, right click on it. Choose run as administrator. Then when presented with the option, choose Repair. After the installer repairs the installation, shut the computer down–power off. Then reboot the computer, open your model file and try Send to LayOut.

I think there’s some confusion about how the whole process works.

I click send to layout after updating / saving, the layout tab on the tool bar flashes as per normal to say its now activated the layout page and, when i go to it the page is either blank or not there at all, its all very curious!

I dont think im confused as the system has worked perfectly for me for years. i am very familiar with it.