Layout Dimensions Incorrect 2018

Pulling dimensions off horizontal, vertical and diagonal lines, I am finding the dimensions not changing as I pull right or up, they stay showing the diagonal dimension.

Luckily I caught this when I had a 72x72x72" right angle triangle!!

(upload://lgYur4d9LSt Cyr Trusses 2021-03-23.layout (4.2 MB) yW26amNpzskWngA1V9.png)

It’s a set up error. You’ve modified the scene which wasn’t set up exactly right. You don’t have a standard view set up so it’s slightly off axis. I set up the appropriate standard view in SketchUp and set the viewport to show the component without modifying the camera in LO.

Dimensions in SU.

Dimensions in LO

Thanks so much, Dave!

Can you explain how you did this? I can imagine running into this again (I work fulltime in Sketchup and Layout) and would like to learn how you fixed this.

Jill

1 Like

Hi Jill,

Actually in the interest of time I made a new scene showing only this part and selected the standard Left view in LO. It could have been done with the scene you were using. If you did that, the key would be to avoid double clicking into the viewport to pan, orbit or zoom. If you must use that scene (LO | TRUSS BB) to show K1, you can do that but instead of double clicking the viewport, just drag the edges of it to show the component of interest. To avoid creating problems with link between the model and the viewports it is best to avoid doing anything that results in the scene showing as modified in LO.

You have your model spread out over a fairly large area in the model space. That distance can create problems, too. If I were going to do something like what I see in your model, I would do a few things differently. First, I’d give each of those components a useful name to make it easier to identify. Then I would give each one a layer/tag and I would have them stacked in essentially the same place within the model space. Then each one would get a scene. This can be very quick to set up because you should be able to use the same camera position for all of the scenes and just change which component is visible for each scene.

Then in LO, you can set up the first viewport showing the first truss of interest. Set its scale as desired in the SketchUp Model panel and maybe drag the edges of the viewport to show the whole truss if you need to. Move the viewports on the page the way you want it. Maybe that’s centered both horizontally and vertically. After that first viewport is set up, duplicate the page, change the scene to the next truss, rinse and repeat until you have all of the trusses represented.

If you do the same sorts of truss drawings and use the same scene names all the time, you could create a SketchUp template with those scenes already set up. And then you could create a template that is already set up with the viewports linked to the scenes in your SU template. After that you only need to select your new project’s SketchUp model as the reference in LO and those viewports will automatically show the trusses. You’ll only need to dimension them afterward.

BTW, you should make sure you are using Layers/Tags correctly. All edges and faces should be left with Layer 0/Untagged assigned to them. I fixed your model.

Screenshot - 3_23_2021 , 2_27_18 PM

It’s also a good idea to purge unused stuff once in awhile. Otherwise your file can get bloated.
Screenshot - 3_23_2021 , 2_26_52 PM

Thanks again!
How did you “Process” the model to move edges and faces to Default?

You should see if you can get your boss to let you upgrade to SketchUp/LayOut 2021 because what I described could be even easier and would take less time and use fewer scenes. I made a quick example with a few of your trusses.

IN SU I created a Tag folder for the collection of trusses (tags replaced layers in SketchUp 2020 (or was it 2019? I forget.) and a tag for each of the trusses. Those trusses are all stacked in the same location and a scene created.

In LO I have that scene selected and I have the scale set. Notice in LO2021 there’s control over the tag visibility for the scene.

Now I’ve got all the tags except for Truss BB turned off.

And here all I’ve done is duplicate the page, turn off Truss BB and turn on Truss E3. Same scale for the viewport. I could keep duplicating the page and switching the visible tag until I have all of the trusses shown on their own pages. It’s all the same SU scene, though.

In LO2018 which you are using it would be changing scenes instead of visible tags.

1 Like

You’re welcome.

I used a plugin called Default Layer Geometry which was written by TIG and is available at SketchUcation.

1 Like

Thanks,
I have 2021, but until they fix the Greyed out Tags when they are turned off, I won’t be using it. It is impossible to read!

I’ve seen others report that, too, but I don’t have any problem seeing them when they are turned off on my screen.

Oh well. Maybe this will be useful for someone else.