Layout 2024. Dimensions are not as per the model

I’m having a problem with dimensions in layout. I get the same dimensions for all sides of a triangular plate that does not correspond to what it is in Sketchup. I have done this type of many times in the previous version of layout. The dimensions are not overrides.

Can you share the LayOut file?

Activate your ortho check.

Those distances are from point to point not in a horizontal or vertical plane

If manually ticking the Ortho box is required as @rtches suggests, better to set the camera to Parallel Projection for the scene in SketchUp than modify the Camera properties in LayOut.

Those are common problems with roofs

1 Like

Good Day Dave,
Thanks for your response. Yes I can.
MC-SC-PL804-0 Discharge chute.layout (1006.8 KB)

The Ortho box is ticked and it is in parallel projection in the Sketchup scene. I have tried every option I can find. Also set the axes manually and by using the context menu “align axes” & “align view”. I didn’t have this issue in 2023 version.

Is there something weird going on with that scene TCDC6…?

The axes looks like it’s in perspective but the menu is reporting it as parallel…?


I can’t seem to change it to parallel.

Hi Paul, all the scenes in Sketchup are in parallel projection.
8 plates are triangular and 4 have the same problem. 4 work just fine.
TCDC4,6,8 & 10 present this issue.

I’m not an expert but I think it might have something to do with changing the axis of parts.

I copied TCDC4 out of your model opened a new Sketchup file, pasted it, saved it and dropped it into the layout file. It dimensions fine. So it’s not the parts, or the layout drawing, it’s something to do with the whole assembly.

I found orbiting behaved differently in your file depending on the scene, so maybe someone with better knowledge can look into that and explain what’s going on?

Is there a way to purge a layout file?
I have tried the “Reset” in viewport and in tags.
It’s inconsistent, four dimension fine and four are clearly not true to the view. The scenes in Sketchup are created the same way.

In File > Document Setup > References, there is a Purge option but this just deletes any files associated that are no longer in the current document.

I’ve had another look at it and I still think it’s something to do with the axis being changed in the scene tabs in the Sketchup model. Whether this is a process error and you’ve done something wrong or it’s actually a fault within Sketchup itself, I do not know.

Hopefully one of the Sketchup experts on here can figure it out.

Thanks, yes just references that are no longer in the document.
It appears that the plate with a sharp point (small angle) present the problem.
The plates that have more acute angle work fine.
Hopefully someone can resolve it. Maybe I’m doing something unusual, but I do the same axes settings to all the plates.