Layout Dimensioning issue

Good Day.
I am freaking out as I am trying to use Layout to submit documents for a permit to build a porch. I cannot for the life me get the dimensioning tool to work on certain scenes. On some scenes I am able to dimension and others scenes the dimensions hide behind the scene. All the scenes I am trying to dimension are using the exact same style. I have tried to move the scene to the back, so the dimension shows up in the front. That doesn’t work.

I am so beyond frustrated as I could have hand drawn this document 4 times over. I know there is a learning curve with this stuff, but I cannot make this work and I am holding up a customer project over it. I would appreciate any help you can give me. Thanks

Upload the .SKP file, then someone will be able to assist with your concern.

I think I uploaded what you need. Thanks.

The link did not show in your post

(removed linked documents) Try now.

Try making a layer called…Dimensions, re-order the layers so the Dim layer is at the top of the stack and the default layer is at the bottom. Lock the default layer so as not to accidently modify it. Make the dim layer active.

Thank You. Thank You. Thank you. That worked.

This sounds to me as if you have your “scenes” on a layer or layers higher in the Layers list on some pages than the layer on which you are placing your dimensions. You should have a Dimension layer near the top of the layers list and keep the viewports on a layer or layers lower in the list.

Best thing is to make a template with the layers set up that way.

Yep. That is exactly what was happening. I am starting to be more diligent about layers in Sketchup but I wasn’t paying attention in Layout. Its frustrating I wasted two days trying to make all this work, but now I know for the next permit document.

Keep in mind that layers in SketchUp are not layers in the same sense they are in LayOut.

Before your next permit document take the time to create your own custom LayOut template and set up layers for the types of entities. Here’s a screen grab of the layers in one of my templates. Note that the Dimensions layer is near the top. It and the “Art Text” layer are for text entities that are specific to the project. There are other text layers near the bottom but those are for text around the perimeter of the page and would never be covered by viewports.

I also set the lowest Model layer as the active one before saving the template so that when I send me SketchUp file to LayOut, the first viewport is automatically on the correct layer.

Hi. My dimensions disappear on my floor plan model. At first, I thought they were below it, so as a test, I deleted the field on one element. That does not fix the problem. I can draw dimensions outside the model. This is the first time I’ve encountered this. I read this thread, but not sure it’s the same problem. I do not know how to make layers in Layout, and this is the first I’ve even heard of Layout layers. I’m a long time user but not a tech person. I can go months without using Sketchup. Maybe I missed something in the latest versions? Any help is appreciated, and remember, I’m not very technical, so please spell things out for me!

If you share the LayOut file it would be a whole lot easier and faster to get you sorted out.

Also please complete your profile with SketchUp version. That information helps us help you.

Layers are created in the Layers panel. If you don’t have that already displayed, go to the Window menu and enable it.
Screenshot - 7_14_2020 , 11_13_31 AM

In your file the view of your floor plan is on the Default layer (indicated by the blue square nest to the layer name, but you have the On Every Page layer active as indicated by the pencil icon. Since the Default layer is above the layer on which you’re putting your dimensions, the floor plan will obscure the dimensions.

In addition to that, since the layer you have been adding the dimension on is a shared layer (indicated by the icon at the far right of the layer name, those dimensions will show on every page.

Here I’ve added a new layer above the Default layer by clicking on the + in the Layers panel and I named it Dimensions. Then I selected all of your dimensions, right clicked on one and chose Move to Layer and put them on that new layer. Presto! They all show up just fine.

Oh, okay. Thanks! That seemed to work. Is there a tutorial for Layout layers you can recommend?

I’d start with the LayOut Essentials here:

Thank you!

You’re welcome.

By the way, you might want to edit your post and remove that LayOut file since it has your phone number on it.

Okay, need to figure out how to do that!

Click on the pencil icon at the bottom of your post. Select the file and hit Delete.

By the way, I had a look at your SketchUp file. It would be a good idea to keep it clean. I reset the edges and faces to Untagged. Only groups and components should get tags.
Screenshot - 7_14_2020 , 11_23_23 AM

And then I purged unused stuff from the file.
Screenshot - 7_14_2020 , 11_23_40 AM

Thanks, again!

1 Like