Layout crashing immediately upon opening MAC

I have a Macbook Pro running Big Sur. I have been able to install SKP Pro 2021 (never had Sketch Up installed before so a ‘virgin’ install, not an update) and it seem to be working fine so far. Layout on the other hand crashes upon opening. Immediately. Every time. It makes no difference if I try to open from my task bar or send to layout from a skp file.

How did you install? Did you drag the SketchUp icon into the applications icon in the window that opens? Are SketchUp and Layout both in your applications folder?

Yes, dragged the icon into application file. Both Sketch Up and Layout (as well as Style Builder) are in my applications file.

Do you mean they are in the Applications folder, or they are inside a SketchUp 2021 folder, inside Applications?

Did you get a bugsplat report, and send that in?

They are in a SketchUp 2021 folder inside Applications.
Yes, got and sent several bugsplat reports. It’s been years since I’ve needed to send a bugsplat report but I do every time.

1 Like

I asked because I didn’t find any under your email address. Do you fill in those fields, I can then find them? Or, you could tell me an exact time that you sent one in, and I should be able to find it.

I thought I included my info in at least one.
Exact time–hmmmmm. My history shows a record of #43073 and #43071. I know I deleted some others with different numbers. They were within a few minutes of one another.

I just created a new one at 13:14 CDT (Sunday, 18 Sept) with the message: Trying to get layout to open after installing on Mac running BigSur. Bugsplat gave me Crash #43106
Does that help?

Thanks, those numbers got me there quickly.

@Adam do you see what is the problem in the crash report for #43106? LayOut 2021.1.331.

@MizeDesigner @colin, it looks like the welcome window is crashing when attempting to close, prior to opening the main window. I can’t see anything more specific than that.

Have you been able to open a LayOut file by double-clicking it to open? When you open LayOut directly (rather than by sending a .skp file to LayOut or opening a .layout file directly), do you see the welcome window, or does it crash before it even opens?


I wonder if waiting for the recent files thumbnails to finish drawing might help. Pretty sure we’ve done some fixes in that area.

@adam @colin
Yes, I am able open an old LO file (from SKP 2020) by double clicking.
When opening LO directly, I do not see the welcome window. The next thing I get is a crash notification.
When I send from SKP, occasionally (but not always) it seems it is going to open and I can see the windows (shape style, scaled drawing, layers, etc.) but then it crashes.


@adam @colin
I realized some other programs were not working properly so I updated the Java install and thinking that might be some? part of? the issue with LO, tried to open it again.
Wouldn’t open at all directly so I tried sending from a skp file. I got the welcome screen and even got as far as seeing a page in LO . . . then it crashed again. Sent Bugsplat report #43161 ca. 22:55 CDT.


Me and Adam are both in Vancouver this week, and a bit behind on checking the forum.

I don’t think that LayOut relies on Java, but some apps do, and those usually need the legacy version. You could install that from this page, and even if it doesn’t help LayOut it may help your other applications:

Thank you for responding.
Already installed and updated Java.
Will look forward to more thoughts/ideas/possible solutions when you return from Vancouver.


@MizeDesigner Have you tried installing the latest LayOut 2022 release? There have been some changes that should improve the stability of loading LayOut files in that release.

Additionally, there is a known issue with LayOut, where choosing to ignore or skip updating to the latest version causes LayOut to crash.


I’ve just had a user with a similar issue in 2022 on an Apple Silicon device

I had to disable access to google drive in the privacy and security section of MacOS and then Layout would load.
I’m not sure what has caused that , although I see Google Drive’s client had an update on the 11th of October (which this user had not received)

So despite supposedly removing access from MacOS in those settings, once Layout would open, I was able to open a file as normal from the user’s google drive.

I am a little confused about how an issue with skipping updates could play into it since this is a virgin install on a new machine.

I don’t have a license for 2022. Long involved story. So I need to sort this out under these constraints.

Worth a shot. Thanks.
Will advise.