Layout crashing constantly

I’m using Layout 2024 on a MacBook Pro M3 Pro. I open a layout file, it prompts me to update the referenced file and in doing so the app crashes.
I’v tried everything including checking referenced sketchup file for issues, purging any unnessecary items, but nothing helps.
Updating the refenmce anywhere in the layout interface causes a crash.
Changing scenes in a referenced sketchup file, causes a crash.
I can’t do any work at all… Other than sending contractors screenshots of SketchUp drawings I’m not sure quite how to get Layout drawings issued…
Any advice appreciated.

1 Like

I’m having the same problem. LO 24 is broken.
Do you have SU 2023 installed?

Are either of you using Match Photo scenes?

Not using Match Photo in SketchUp.
I’ve reverted to using SU 2023 to work round the problem… hoping for a fix soon.

The developers need more info, I suppose…
What happens if you create a new file with a standard template, save and then send to LayOut?

It might be a setting in the template that is used.
Usual suspects are scene settings and styles.

Thanks for the advice - I have around 10 scenes in mySketchUp file, one of them was using a distinct style that I got rid of and that seems to have stopped the crashing.
So in this instance a Style seems to have been causing the problem.

1 Like

Apologies for delay. I don’t get notifications when there are new responses for some reason. I had tracking switched on.

LO24 just crashes on opening a file. Not even that big.
I tried opening up after leaving it for a few days. It wouldn’t open at all at first- Then I opened as administrator and it worked.
It still crashed out though. I can’t afford to use it right now.

I downloaded the latest update hoping that the LO problem would be resolved. It’s still crashing out and unusable unfortunately. It’s a pity because when I was using it before it started glitching the performance was really improved. I hope it gets sorted soon. Until then I have to stick with 2023.

LO 24 won’t start at all now. I tried running as administrator- Nothing happens. I noticed that when I was able to get it to start previously the icon showed up blank in the taskbar.

Hi Le_Corb, we had a mac user during beta run into this similar issue but the issue just went away for him and we were not able to repro it. It seems like LO is trying to open a file on launch, maybe recovering a file from a crash that no longer is in the same location or the file may have been corrupted for some reason.

Could you try to navigate to:

~/Library/Application Support/SketchUp 2024/LayOut/

and delete the .json files then relaunch.

Fingers crossed this does the trick.

Trent