Layout bug when switching to vector

choosing vector for my “viewport” causes the style to be ignored and suddenly all linework is visible. choosing raster changes it back to correct look, but i need vector.

Hello florencearchitects

Are you using a custom created style or one of the styles preloaded in SketchUp?

What you are seeing is most likely not a bug but as designed. If you are using a style that has edge treatments (extensions, endpoints, jitter, sketchy graphics, etc), these characteristics will not translate to vector as they are just decorative elements. Vector rendering the viewport creates vectors for the geometric faces and all true geometric edges in the model. It does not try to interpret the decorative elements applied in a style.

I hope this helps clarify what you are seeing.

Cheers
CD

@florencearchitects can you provide a screenshot of the image you would like to be displayed as a vector? There may be a workflow to get what you are looking for.

– Matt

I have the exact same issue. It isn’t a style problem… I do not use fancy styles, the vector render just makes the model transparent. I do not know how to fix this…

Can you provide a screenshot or if possible a sample files of what you are seeing?

Have you tried updating your graphics card driver? Somehow it seems that in newer versions of SketchUp and LayOut the graphics card/driver has a role in printing and exporting.

Anssi

Yes. the problem is the new Hardware render settings in layout… If your video memory maxes out it will not render correctly.

This function gave me a headache and needs to be fixed. We should be able to turn of hardware acceleration for vector graphics without losing raster hardware acceleration.

You can turn off hardware acceleration in sketchup which also effects layout rendering. But you end up turning it on and off all the time…

There is a work around that you can put in regedit. This option should be an option the preferance pane of layout…

Se http://help.sketchup.com/en/article/3000062

Got a weird bug too with Layout 2018… In vector mode, it creates faces in random place!! Check out the snapshot. Anyone have an idea?

It’s a very bummer situation as I will have to switch to raster!
My graphic card driver (GeForce GTX670) is all up to date, my Win10 pro as well.

Hi JoeDrafter, we have a similar issue when using Filled Section cuts. One way we have found to resolve the fills is to adjust your viewport edges (in or out). This causes a re-render in the SketchUp code and we see at times the fills go away.

If you would not mind sending me this file I will add this case to the issue.

trent@sketchup.com

Thanks
Trent

Thx for the reply trent but I know this trick and it didn’t work! I actually have the problem in Elevation as well, and it’s kinda worst!!!

I’ll send you the files skp+layout…

We’re having the same issue - see attached screen grabs taken from Layout. Large areas of floor, which aren’t sectioned, are shown with a section fill in the vector render. Furniture sitting above the floor, also not sectioned, does not appear with section fill in the vector render. There is no logic to it!

I’ve read somewhere that this issue may be due to file size but we have deleted and purged the SketchUp file and can’t reduce the file size any further. We’ve moved the section plane on other models and successfully overcome the issue after multiple moves but that ‘trial and error’ approach is not acceptable generally and doesn’t work on this model.

Please help!

VECTOR:

RASTER:
image

I jrk, would you be able to email me the file?

trent@sketchup.com

Thanks

Thanks Trent. This fixed my issue today, where manually drawn fills (not section cuts) were not appearing in Layout. I released the views clipping mask, adjusted the viewport edge and then reclipped.

That is great to hear.

Trent