Layout 2023 as default to open layout files in Windows

How do I set Layout 2023 as the default to open Layout files? The default file type set up in Windows does not show Layout as an option. Tried it from both directions, from file type and from program, no luck.

If you installed SketchUp correctly LayOut files (with the extension .layout) should automatically be associated with LayOut. First try repairing the installation of SketchUp and LayOut. Close both applications, find the downloaded installer, right click on it and choose Run as administrator. Then choose Repair when that option is presented.

What program is currently trying to open your LayOut files?

1 Like

Hi Dave,

I ran the repair. No change. Currently the layout files have no association to an app, they show as a white rectangle.

In screenshot 222, I tried to right click and ‘open with’. When I click on ‘choose another app’, Layout does not appear on the list.
In screenshot 224, I right clicked and went to ‘properties’ and clicked ‘Change’ under ‘opens with:’, Layout does not appear on the list.
I also tried setting the default from the ‘choose default apps by file type’, but Layout does not appear as an option.

Otherwise, Layout is working fine, I can open Layout files from Layout and from within SketchUp after saving a file, so this is just a slight nuisance.

Set up File Explorer to show the file extensions.

Note: you should not be working on files directly from DropBox or other cloud storage sources. You should be downloading them to your local drive and opening them from there.

In my setup, Dropbox is just a folder on my local drive that syncs to the Dropbox server, I’m not on Anyway, I saved a Layout file to my desktop, same issue. Explorer shows the file type as .layout However, double clicking on the file to open brings up the 'How do you want to open this .layout file? and there is no way to access the Layout program from there.

I am having problems with Layout also.
I have one file that keeps showing a red “x”
Corrected existing master suite.layout (222.4 KB)
When I try to open it I get a message that there is a new version of SKetchUp to be installed. I already have the latest version, but I have gone ahead and reinstalled it, opened the file and saved it and it seems to work, but the next time I look in my files, whatever folder has that document has the red “x” again

I don’t see a red X when I open the file you shared. Can you show a screenshot of what you are seeing?

The new version popup has nothing to do with what you are seeing in your file.

I do see that you haven’t created any scenes in your Sketchup file which means you are opening yourself up to some real problems as you proceed with your document.

Is the red x within the Layout file or is it in Windows Explorer ?

How about a screenshot of the x ?

This is how it looks.
I mentioned the new version popup bc that was only popping up when I opened that particular file.

OK. It wasn’t clear from your post that this red X is showing in File Explorer. A simple Google search indicates that the red X indicates that Windows has no connection to One Drive where the file is actually saved. Best practice is to save your files on your local, internal drive and sync them to One Drive or other cloud storage. Do not work on files directly saved in the cloud.

Thanks so much for your responses.
You might be able to see that there is also a red X in my documents on my PC. This corresponds to the same file.
It is not a major issue, I just wondered if anyone had seen this

Yes. I saw that as well as the one higher in the tree for OneDrive. Sign in to OneDrive and the red X should go away.

Thanks, It is still red in my documents on my PC which does not require a sign in.