Layout 2021 crashes when inputting text

Area Near the Pavillion amended 9 - Arial.layout (143.0 KB)

My customer sent me this layout file reporting that it crashes when she tries to add text. I’ve had a look and with my limited knowledge cannot see what might be a problem. I can repeat the error. Add a few text boxes, they don’t have to contain much text, and a BugSplat appears (I have submitted it)

I have tried changing all the text to Arial from the mix of Verdana and Arial but that hasn’t helped.

Can anyone give any pointers as to where the problem may be.

I’m on Windows 10 with SketchUp Pro 2021 she’s running a similar set-up.


Have tried removing the compass image bottom left, makes no difference

Checked File > Document Setup > References and removed/purged missing elements, again no difference, BugSplat or spinning wheel after 5-10 text boxes entered.

Windows 10 SketchUp/LayOut 2021.1. I’ve added 13 text entities so far with no problem.

Strange thing is that I downloaded the file that I uploaded to this forum and I have no problems with that yet if I go back to the one my customer sent or the one I had on my computer I get the freezing.

What happens if you send the file back to the customer or have them download it from here? Do they still experience the crashes with that copy of the file?

Have done that and waiting for feedback

Area Near the Pavillion amended 9.layout (140.9 KB)

This is the original file I was sent, I’m uploading it so that I can download it to see what happens

No, that didn’t solve anything crashed after 12 text boxes

Tried restarting my PC but BugSplatted after 8 text boxes. I’m just clicking the text tool then on the page, typing text then clicking away from the text and clicking again for the next entry.

I got through 14 text boxes on that latest file but after setting the 15th, it splatted. I sent in the Bug Splat. Maybe @colin or @adam can take a look and identify what happened. Crash 15580.

I was born in Cheltenham, and lived in Beckford for four years as well. Been to Evesham a few times!

Can you show enough of her email address that I could use to search for the crash report? Assuming she sent one in.

I sent one in as or

I can create another if you need it.

I don’t live in Evesham, in a little village just outside, ideal area for cycling, just on the edge of the Cotswolds

Hi @colin have you been able to find the BugSplat data and look at it?

I can’t remember what I found at the time you last posted, but at the moment I can’t find the bugsplat.

At the time you were asking we were busy getting the 2021.1.1 version ready, which kept me a bit busy. Have you been able to try the same tests with the new version?

The problems were with the latest version

@DaveR also sent in a BugSplat “I sent in the Bug Splat. Maybe @colin or @adam can take a look and identify what happened. Crash 15580.”

Thanks for that. Dave’s crash was on June 25th, and he was using 2021.1. Having got into the right crash type I was able to see two crashes from you, that were both June 24th. You also were using 2021.1.

Looking at all crashes of that type, a lot less have happened with 2021.1.1 than with 2021.1. Check your Help menu, About SketchUp, and if it doesn’t say 21.1.299, it’s still on 2021.1.

From the other crash reports I can see which of my colleagues were investigating this issue. Trent is one of them, but another colleague seems to have done more testing. I will ask what the state of the issue is, and whether it was thought to be fixed 2021.1.1.