LayOut 2020.2 - one file ONLY Bugsplat every time

I have been a Sketchup/Layout user for about 15 years but never experienced a bug issue that I couldn’t find a solution to or workaround. However, with this one I am stumped and hope that someone can help.

I am working on a LO document (on and off for the last 3 months) with links to a single SKP model and numerous annotations and labels. All of a sudden yesterday afternoon it crashed whilst moving a label group and now the file won’t open at all and crashes LO whilst attempting to open. Other LO files I have been working on recently open and operate without any problems. Sketchup is operating fine and the model linked to the ‘dead’ LO file is stable.

I thought perhaps the linked SKP model had some recently imported 3DWarehouse components that were causing the crash so I deleted these out, saved the SKP file and tried opening the LO file - same problem.

Can some kind soul with expertise please make suggestions as to what I can try next, please? Many many thanks in advance. I am under some time pressure with this project and am looking to rescue about 30 hours of work which will need redoing if I can’t access the LO file.

iMac 27" 2017
3.8 GHz Quad-Core Intel Core i5
Catalina 10.15.6
8 GB 2400 MHz DDR4
Radeon Pro 580 8 GB


LayOut files are really zip files, and the SketchUp model it is using is embedded. If the zip package is corrupted you could rebuild that, and while you are doing so you could replace the suspected model file.

Try this:

  1. Duplicate the LayOut file and change the duplicate’s name from .layout to .zip. Say Yes when Mac OS asks you to confirm that you want .zip as the extension.
  2. Double click to expand the zip, that will give you a same named folder.
  3. Inside that folder there is a ref folder, that will include the embedded SketchUp files. Replace the suspect one, making sure to keep the name the same.
  4. Back at the first folder level, select all, right-click, Compress 8 items (or whatever the number is).
  5. Rename the .zip to be .layout.

Does that new file work?


Thanks Colin,
I tried that but as I mentioned I didn’t think that the SKP file was the problem and again it crashed on loading. It was interesting to learn more about how LO files are assembled.

HOWEVER!! I remembered I had saved a renamed version of the LO file earlier in the morning to split out certain pages for a different presentation. But I hadn’t begun editing it so the pages I thought were lost were there and only 3-4 hours work has been lost. Success - to a degree. I started carefully editing the document, saving after each edit and discovered something strange:

There are 2 dimensions which won’t delete off the page in the normal way - If I select the entity (extension lines and start/end arrows) then hit delete, the auto-text doesn’t disappear. When I attempt a save after ‘deleting’ in this way an “error code 109” is flagged and I can’t save the model. BUT - if I select the auto-text and hit delete, then I select the dimension as normal, delete it and save, it seems to work fine. It’s as if the auto-text has a ghost.

I have recorded a screen capture of this process and can send to you if you would like (>1min). I have also saved a copy of the original backup file which shows these 2 ‘rogue’ dimensions in their original context; they were part of a ‘scaled drawing’ group and everything else in the group deleted fine.

Thanks again for responding and trying to help. let me if you want to see the files.