Layout 2021 file not opening. sometimes says: File not found or invalid

Layout File: BGL11_Dropbox

I wish this was a more interesting topic but such is life!

Since using the new Sketchup 2021 my Layout AND Sketchup files are playing up.
Sometimes getting the message; File not found or invalid, so I have to revert to an older version.
Sometimes they just won’t open up at all (and still get the occasional crash).

Any wizards out there with special powers…please pull up a chair!

This Layout file stopped opening last night.
Today I have continued to work on the associated Sketchup file.
I have just been through all of the Tag Folders and sub-folders and created ONE component and on it’s own Tag, for ALL models downloaded from the 3D Warehouse - because I read on another thread, that it could be caused by something dodgy that’s been downloaded.
So now in the Sketchup file, I have hidden ALL of these models within the file. Just in case this helps. Only problem, is that I can’t test this theory, because the Layout file simply won’t open at all. And there’s no warning message. I’m rambling.

I can upload the associated Sketchup too if needed.

Any help most appreciated.

Oli - in London

2.4GB… that’s huge!

Doesn’t bode well (imho)


If you had access to that quantum computer featuring in His Dark Materials, you might do better!

1 Like

Yes indeed. There is quite a bit of vegetation in there and other stuff from the 3D Warehouse. But the file should surely still open up…

Aren’t you too old for that Simon

I’m getting…

Error reading Layout file

thanks for downloading, Paul!
What would you do next?!

I’ve renamed the file to .zip and have tried to unpack the zip file but I’m getting an interrupted action…

It’s trying to unpack the after crash skp but failing

How very dare you! It is shown at that funny time per-watershed and post children’s TV. Anyway, I only watch it for Ruth Wilson…

1 Like

“It’s trying to unpack the after crash skp but failing” you say…

“after crash”?

After a crash a few days ago I named the next saved version of the file as: “BGL 07 after crash”.

Is it somehow still looking for that file?!


I renamed the layout file as a zip file extracted the contents and deleted the after_crash sketchup file.

I re-zipped all the files and renamed it as a layout file and…

after some time the file opened in layout!

I’ll see if my Dropbox account is still active

So wizards are real!!! That’s amazing!!!

It is on at a weird time.

In the last 10 years I have had to read the trilogy three times to my children!

So I end up shouting at the TV “That didn’t happen in the book”

Where are you storing your files? Are you working directly from Dropbox or a folder synced to Dropbox or other cloud service?

The BG162 After Crash_321.skp file is corrupt for some reason, so I removed that from the LayOut file, and then it opened ok.

You will want to relink all of the SKPs listed in File/Document Setup/References, if you see them as missing. The blank entry is probably the BG162 After Crash_321.skp that I removed.

I tried one of the >600MB SKPs, and purge unused took it from 625MB to 543MB. Saving it as a 2021 file reduced that to 272MB.

Looks like we did the same fixing at the same time, but I had to wait for the file to upload before I posted.

You saved me the bother Colin - thanks :slightly_smiling_face:

Amazing guys!! Really bloomin’ marvellous!!

I will download it now. (I’ve just been for a run to get the blood flowing again).


I fear I may be cursed by this problem again in the near future… I think my main Sketchup file may have gremlins deep within.
Since using Sketchup 2021 (LOVING THE TAG FOLDERS!!!) it is behaving very oddly indeed.

I am now ‘Saving As…’ around once an hour, because the problem only occurs when I try to open up the file after it has been closed. It works fine while it’s open, just after It’s been closed I then can’t reopen it, and have to revert to an older version… like with my Layout files…

But anyways I will go ahead and download this Layout file and relink it to the latest Sketchup file.

If I was to upload the Sketchup file now, would anyone like to take a peek?!! or should I wait until it fails to open up?
When it fails it says File not found or invalid, which sounds darkly terminal to me…

Hello Anssi,
I’m using a Mac, and all my files are stored in folders on the desktop, but yes indeed they are synced to iCloud. Do you think this could be an issue?

for me, iCloud is great because I use a MacMini but also a little MacBook Air, so it’s great to have them in sync all the time…

I think @colin can tell you more about known issues with iCloud. Just generally speaking, storage over the Internet is not as reliable as on a local drive, and I wonder if the ongoing syncing can also introduce errors in the writing process. It is also not recommended to open large files like SketchUp models directly from removable storage devices like USB sticks.