Layout 2018 not snapping correctly

I just installed Layout 2018 and I am having a few issues with it. In the 2017 version, I could hover over a point while drawing a line to tell it that I want it to align with that point. In the 2018 version, that is not happening anymore. Object snap is on, grid snap is off. Please help, this is such a pain!

I should add, it snaps properly sometimes, but more often than not it isn’t

Hi Krisanna, are you not seeing inference points at all?

We made some changes with our inference engine in 2018 so that it would not hang on to as many inference points as it did before. This was to ‘cool’ down our inference chatter but we still support inferencing.

Yes! Inference… that’s the word I wanted, but couldn’t remember. It definitely grabbed on to too many inference points in 2017 (in the weirdest places too), but is hardly grabbing on to any now that I’ve updated it.

I’m also having some problems with opening layout files, I tried to repair the download in case something didn’t get installed properly, but I’m still having issues. Not sure if it is connected to the issues with inference points.

What kind of problems opening LayOut files?

Also, are you seeing anything strange in SketchUp?

Trent

When I hit “send to LayOut” in SketchUp, it only works if LayOut is closed. I also can’t open LayOut files from their folders, I have to go File>Open and find the files.

We only use SketchUp to scale drawings to use in LayOut, so I’m not sure if anything strange is happening there.

Hmm… This is strange behavior for sure … Please try an uninstall and reinstall of 2018 vs. a repair and see if that helps.

Trent

I’ve just tried that and I am still having all of those issues :thinking:

Hi Krisanna, just to verify, you are on Win 10 and have a Intel 530 card… correct?

I am on Windows 10, processor is Intel Core i5-6400

Cool thanks… and your Graphics card is a 530?

Yes it is

Hi Krisanna, I believe we have found what is causing the inference bug you are talking about.

Below is how to reproduce the inference issue and also how to reset your inferences.

Steps to reproduce
1)Invoke the Line tool
2)Give a start point then Press the Esc Key
3)Give a start and end point then try to inference another entity - Bug… you will not have your inference available

The key to getting your inferences back is to switch tools and then back to the Line tool.

Steps to Get your inferences back (when you find you have no inferences)
1)Press the Space Bar - (selection tool) then press L (to get back the Line tool)

Inferences are back! :smile:

Please note that any other tool can be used to ‘reset’ your inferences and you could experience loss of inferences if you change pages during Line input or possibly using undo.

Please let me know if this does the trick for you.

Trent

That works for snapping to inference points on lines, but it is still having problems snapping to inference points on circles. I use LayOut to draw tree protection plans, so I need to be able to snap to circles, here’s an example of one of my drawings

Are you drawing the circles or are they coming from SketchUp or are you importing a dwg into LayOut?

I draw the circles. We scale a jpg of the site plan in Sketchup then send that file to Layout and trace over it there. It’s a little bit complicated, but it works for us.

Sure… that works… inferences should be available on circles drawn in LayOut, SketchUp and imported from a dwg/dxf.
On Point at the quadrants and a Center point snap.

it worked like it was supposed to when I have 2017, but now it doesn’t work properly in 2018. I can send you a screencast, but the files are too big

here, does this help? https://forums.sketchup.com/uploads/short-url/7QFnH2NQkRvd9fmptW1FusOjLIv.mp4

It does… .looks like we are not picking up one of the quadrants on the circle in this condition. I will log this as a bug.

Meanwhile if you hold the shift down you can constrain the line and still snap to the point you want.

Trent