Layout 2018 not snapping correctly

Fantastic! That will make my life much easier. Thanks so much for all of your help :grinning:

I am also having this issue, the dimension tool cannot find any inference points on my model whatsoever.

Can you share the LO file?

No, I don’t have permission to share the design. It’s a model built in 2017 Sketchup and I had no problems making dimensions in Layout previously. Those dimensions are still attached to the model but I cannot make any new ones.

This works for me, it’s a pain but it’s better than nothing

Yes I saw that suggestion earlier, but I’m trying to use the dimension tool, not the line tool.

That’s too bad, I was hoping it would help. I have always had some issues with having lines snap to my dimensions so I am interested in hearing what they say about it (I realize that your situation is different, but they may have a similar solution)

Just to clarify, this isn’t an object snapping settings issue?


No, my object snap is on. Actually I’ve downgraded back to 2017 and I am now encountering the same problem! But when I built the model in the first place there was no issue with the dimension tool.

Is there perhaps something on a layer that is front of the object, or on the same layer but is creating a transparent window in front of the model viewport? That’s happened to me before.

Hi, thanks for responding. It doesn’t look like there’s any hidden objects. I even tried generating a new layout file from my model, same issue.

Hello, it could be text with a large bounding box… see attached video.

This can get me at times.


@trent That’s what I was guessing, but @mnikolic said it was happening with a new layout file from the model, which shouldn’t have text on it.
Do you think something in the model itself might be blocking the endpoints? Mnikolic, could you try making a really simple model and exporting it to Layout to see if it’s happening on all models, please?

Hi Katya, that was a great suggestion. I tried making a simple box and the dimension tool works fine. I would hate to rebuild me model from scratch but if that’s the only option…

I think the problem lies with my models that I opened in 2018 SU. Even if I try to save them as an earlier version they won’t work properly in Layout, but my older models that I never opened in 2018 are fine.

Frankly I am really disappointed with SU’s handling of this, and I am requesting a refund. I can’t waste more company time redoing all my work.

@mnikolic I sent you a private message. I’d like to keep helping you with this. It would be rough if you rebuilt the model and it happened again, so I want to investigate further, if that’s alright.

Does your model contain any section planes?

Can you provide just a portion of your project so I can see what the issue might be?

This is a bit tough to tell what is going on without an example and we are not aware of issues with older files moving forward.

You can email me directly and not share publicly.

Thanks, I am just going back to Illustrator and will ask for a refund.

Thanks for sharing the model, it took a weight off my mind. It’s solved! Your SketchUp model had the edges turned off, so there were no endpoints to snap to in Layout. If you re-save the scene in SketchUp with the edges turned on, and then just hide the edges that you really don’t want on (the 3D words, perhaps), then you can still get the edges to snap where you want them.
In the Model settings in Layout, you can also make the lines fairly thin if you don’t really want them to show. And in SketchUp you can change the color of the lines so that they blend in if you don’t want them to be obvious.

1 Like

Wow! That would have been easily solved in seconds if we’d had even a screen shot at the start. Good on you for sticking with it, Katya.

1 Like