Layout 2018 crashing

I have just created a Layout file in LO 2018 that has a problem. I cannot upload it as it is just over the size limit.

Whilst SU crashes reasonably often for me, LO has always been very stable. However, if I try to turn the embedded files to Hybrid rendering, LO crashes out. I have tried saving and reloading but it happens reliably every time. I have not had it happen before.

The SU file has PDFs embedded in it and I cannot lock them or the layer they are on. I don’t know if that is normal or if there is something about the PDFs that SU doesn’t like and is somehow causing the crashes in LO.

Any ideas anyone? That includes any suggestions about how to share a file that is too big to upload (Trimble Connect? Haven’t used it before).

1 Like

If it is only a little too big, try compressing it (make it a Zip file) and upload the zip file here.

Or use a file sharing service like Dropbox, OneDrive or Google Drive, and share the link to it.

Tried compressing it. It went from 4.2Mb to 4.1Mb! Still too big. So here’s a link instead:

A LayOut file is in fact already compressed: if you rename it to .zip and unzip in a folder, you can see how it is built up

I am finding that Layout crashes every time I try to change from raster rendering to hybrid. It has nothing to do with corruption and is unrelated to the specific drawing I posted. That never happened in 2017. Could this be a bug? Any way round? It will prove quite limiting of not.

Aaaaaagh!!! I just tried going from raster to vector rendering and that crashed the whole computer. Is this just me or have others encountered this problem?

If this doesn’t get fixed, I will have to start saving in 2017 format and then use LO 2017 for rendering.

1 Like

It works fine for me.

Are you on a Mac, Dave?

1 Like

This is on my PC.

I managed to change all your SketchUp views to hybrid. Some of them took about 10 seconds, but they worked.

A kernel panic is serious. Maybe this is a graphics card or driver issue?

Edit: I’m on a Mac, but not the same hardware as you.

Aw shucks, that doesn’t work either. LO2017 didn’t like opening an SU 2018 file saved in 2017 format. Stuffed!

I don’t know what a kernel panic is. Is your hardware more advanced than mine? 2017 worked fine and I don’t think I have incompatible hardware issues AFAIK. Doesn’t seem to affect any other software. How can I check what might be going wrong?

When you said this:

I took it to mean a kernel panic like this: If your Mac restarted because of a problem – Apple Support (UK)

It doesn’t have to be more advanced, just having a different graphics card from me could mean the difference between it working on one machine and not the other.

This is on my 2009 MacBook Pro running El Capitan. Hybrid render of both viewports took only 2 or 3 seconds each.

I think your diagnosis is probably right. Reading that article shows exactly what happened with the vector option. With the hybrid option it is just LO that crashes. I note that the article says:

In most cases, kernel panics are not caused by an issue with the Mac itself. They are usually caused by software that was installed, or a problem with connected hardware.
To help avoid kernel panics, install all available software updates until Software Update reports, “Your software is up to date.” OS X updates help your Mac handle the kinds of issues that can cause kernel panics, such as malformed network packets, or third party software issues. For most kernel panics, updating your software is all you have to do.

I have carried out the checks suggested but nothing abnormal found.

Curiouser and curiouser. Not sure where to go though.

You could go here

https://help.sketchup.com/en/contact/technical-support

@simoncbevans, it even works on my old iMac with it’s miserable graphics card…

what are your SketchUp >> Preferences >> OpenGL settings…

I believe LayOut uses these setting as well…

john

41

Thanks. Have reported the problem.