Layout 2018 can't export PDF error "There was a problem exporting to this file"

Thanks for the

:grinning:

I’ve very quickly scanned them and the vast majority of these talk about large / memory intensive images being the cause of the issue. However, as @chaz_plan, myself and others have mentioned, the error message comes up when exporting a blank document (from a standard template) so there are no images / vector files in it to cause and issue.

Also, several of these threads seem to be saying
“if you can’t print to Acrobat PDF then install a different PDF authoring app and select that to print from”
but this overlooks the problem - I can PRINT to PDF but I can’t EXPORT to PDF.

I’ll have another look tomorrow but, if you say that Cute PDF maker works, is there any way I select it to be the PDF author (rather than Acrobat or Microsoft PDF Writer) when using the EXPORT PDF command in LO?

Cheers

Sam

I am with @Samyell on all issues as we parallel all the pdf export problems and tried work arounds… I can PRINT to PDF but I can’t EXPORT to PDF… and agree is there any way to select the pdf author when using export pdf command, it may unlock the issue? Chaz

In my experience, the Export to PDF command has never worked in Layout. However, Print to PDF works just fine and produces the same result. If you use an unusual paper size, you may need to create it first.

I’ve used the Export function ever since I started using LO, ~10 years ish. Until I started having this error message I would positively avoid the print function as the export function has more options and retains settings - always found export much easier that the print function personally. It stopped working for me on one PC back in October and another in November. If its never worked, perhaps you have the same issue @novurba - what error do you get when you try to export?

I have decided to give up on LO exporter and go print to pdf using Primo pdf or Nitro, I have tried Cute but prefer Primo/Nitro. Primo is free to use and then if you like it progress to Nitro the full blown program, here is the link: https://www.primopdf.com/ the end result is the same and no hopping around in LO on different machines.

Layout 19, same problem after win 1903 update

1 Like

So, this is what we’re beginning to see lately and it does seem to coincide with the 1903 update (which is, as I understand, not reversible). It seems, for the time being, we have to rely on Print to PDF or using something like CutePDF Writer to get the output until we can figure out what’s going on with it.

If anyone is running a beta of the September Windows update (19H2), would you mind giving the Export > 2D Graphic > Format: PDF File (*.pdf) a try and see if it works?

I am temped to believe the issue is local not affecting all users. I am on 1903, 18362.267.
PDF export is working.

1 Like

Good to know! Thanks for that bit of info. I couldn’t imagine that it was a universal issue… if so, we’d be getting a scary number of calls.

Has this issue been solved? I am on a MAC. I am not a tech expert but its critical I can PRINT or EXPORT from Layout Pro 2018 to PDF.

As a paid subscriber Im blown away this basic function doesn’t work

Any help out there?

Cute only works on PC I went to the website to check if there is a free download - can you suggest a MAC option?

Interesting that the “print to PDF” option wouldn’t work on a Mac, considering Apple and Adobe’s close relationship. Would you mind completing a support ticket and we can work toward a solution. If we find something that works, we can paste it here. You can reach Pro support here: https://help.sketchup.com/en/contact

Greetings.

Here exporting a BLANK FILE WORKS.

Following someones suggestion on a logo that was bugging the file, I decided to check my file over here.
Posting the results in case it can lighten up someones mind.

This page on the left does not export. The page on the right works fine.

Here, the viewport from the bottom left is, somehow, the cause.
If there any tests I can perform in order to help coming up with a solution, you all can count on me. =)

Running Windows 10 Build 18362.
Using GeForce 1060GTX 6GB
SketchUp PRO 2019.2

Best regards!
Felipe

1 Like

No new information, just another person affected and looking for a fix, thanks!

The problem just popped up on a brand new W10 machine which I assume has all the latest updates. We have two seats, both on W7, that export fine. The new one won’t export any drawing to any folder, as reported by others here. Other programs on the new machine (Word, etc.) can export to PDF fine.

When you installed SketchUp and LayOut, did you right click on the installer and use Run as administrator?

Dave, our IT contractor set the computer up and installed SketchUp, so “hopefully” is the best answer I can give. But in any case, has that fixed this issue for anyone who has reported it? Maybe I missed something
in this very long thread. I definitely saw several posts stating specifically that it did not.

image001.jpg

I have seen some posts that indicate it did help. There are numerous threads in which users have reported issues with both SketchUp and LayOut where installing or repairing using Run as administrator while logged in as the normal user, not as System Admin, have fixed the problems. At the very least, it would be a good idea to make sure installation was done correctly.

Incident report:
Just made a Layout file that wouldn’t export to PDF. After some exploring, found a hidden/very small item that was causing the problem. After deleting it, Layout did export to PDF.
Problem is in Page 3 “Top” window.
Bad-File.layout (975.1 KB) Good-File.layout (974.8 KB)

2 Likes

@Ninjoe
Good Find!
Inside the bad layout file the offending item appears to have been a corrupted linear dimension with data like the following

<e:rectangleBase x="-nan(ind)" y="nan" width="nan" height="nan">
<e:affineTransform m11="-nan(ind)" m12="-nan(ind)" m21="nan" m22="nan" tx="-nan(ind)" ty="nan" />
<e:points2f>-nan(ind),nan,3.34375,0.7343749</e:points2f

-nan(ind) is an IEEE floating point representation with the meaning ‘a negative indefinite Not A Number’. I’m guessing that these values should be rational numbers

We can hope that the example you provided will help speed the resolution of a few similar problems.

I hope you might have figured out the problem since it’s been a long time for the issue, I don’t what the issue is, but there is a alternate solution available to make PDF, you can go to “Print tab - print as a file - choose the path - Print” you’ll get the PDF file.

Thank You.

Let me know in my mail id (adeshgupta1996@gmail.com) if it doesn’t help out.