Layout 2016 Dimension Tool Pain in A^^

How am I now supposed to have a line up of dimensions with all my 2015 layout files with this new badly thought out auto dimension tool. The original “449” measurement was in 2015, absolutely no way now to do in 2016. I need all the arrows to be consistent so i can line up a row or column of dimensions!!!

I also have a little dissatisfied about new dimension, but I could control this case.

  1. double click dimension
  2. select only value text
  3. move value text with Up arrow key (check off object snap) (don’t drag)
  4. then dimension line will be inside
  5. adjust the text position again with Down arrow key
  6. select extended line that connect dimension line and value text
  7. change this line’s color translucent value to 0 % (with shape/style dialog, color setting)
  8. done ???

Aah right, I’ll test that in the morning, is there a way to make if default so it does that automatically?

Hi dantheman88988-

Just looking at that dimension, I would not expect the arrowheads to be behaving that way. They should only be moving to the outside of the dimension when there isn’t enough room for them inside the dimension. It looks to me like there’s enough room inside that particular dimension for both the arrowheads and the “449” text box.

Is this a file that you could share with me?

Thanks,
Marc

Hi Mark yes there’s plenty of room and in fact if I turn on units to show mm and make it longer it’s fine. Very buggy, if you want layout to be used seriously as a professional design tool these bugs should never be allowed to happen or at least rectified very quickly

I could store dimension style at scrapbook or template, but I couldn’t find the way to store dimension’s automatic behavior.
May be this automatic behavior depends on FONT’s type or spacing? or something…

You’re correct that this behavior depends heavily on the font rendering system. When LayOut is deciding how to draw a particular dimension, it adds up how much space the arrowheads need and how much space the text needs. If the total is larger than the available space inside the dimension, then the arrowheads are pushed to the outside of the witness lines.

When the text position is set by hand, we do not take the text size into account during this calculation. That’s why your trick in the second post works.

1 Like

Recently upgraded to 2016 and this dimension issue is driving me crazy. Was there a fix for it found?

I am also annoyed by the treshold at which the arrows switch to the outside… (SU 2016)
Wish i could change that, maybe with a button to force inside/outside, like the ones for switching above/center/below…

Maybe the developers could have another look at how dimensions work in traditional CAD programs. There’s lots of good stuff to copy / learn from: running dimensions for instance. I really would like to have those in SketchUp so I’m 100% sure I’m measuring the right point in 3d.