LayOut 2014 Crashes Repeatedly on Startup


#1

Since installing the most recent 2014 SU Pro update I cannot get Layout to launch successfully. The program appears for a split second then disappears, leaving only the BugSplat window. Here’s what I’ve tried…

• Repair permissions and verify disk
• Reinstalled SU & Layout
• Trash system & user prefs for SU and Layout
• Zap PRAM
• Reinstall system OS 10.9.4 from recovery mode
• Took my computer to the Apple store for a look-see. Everything checked out.

Still no luck. Need to get some client work done, but this is holding us up. Have contact SU Pro support twice -no response.

Anyone know where I can find a link to download SU Pro 2013 or an early release of 2014? Thanks in advance!


#2

Launch /Applications/Utilities/Console.app and in the search bar type “LayOut”. If your crash is not annotated there, restart LayOut and let it crash. You can also look for crash reports in ~/Library/Application Support/CrashReporter/LayOut-LOTS-OF-HEXIDECIMAL-NUMBERS-AND-LETTERS.plist (note that “LOTS-OF-HEXIDECIMAL-NUMBERS-AND-LETTERS” means something like 012345-ABC-678-DE-98765-F43210). Send those to our support group, or private message me (if it’s working on these forums) and we’ll take a look ASAP.

-b


#3

All our downloads are at http://www.sketchup.com/Download/all


#4

Hi-

As a shot in the dark, when you deleted the user preferences did you also remove the LayOut directory from Application Support? One of the common causes of persistent LayOut crashes on startup has to do with a corrupt shortcuts.xml file in the Application Support directory - for which the solution is to remove either that file or the entire directory.
/Users/pghedges/Library/Application Support/SketchUp 2014/LayOut

If you get a chance to submit a BugSplat crash report, please put your name on it and then let me know - I can look it up in the database to give you more information.

Thanks,
Marc


#5

Thanks for the reply. Finally got this sorted.

I did trash the SU related folders inside the App Support folder. However, I copied the scales.xml file from an old backup. Turned out that file was corrupt. Trashed it, restarted and everything is good.

Following your instructions from http://help.sketchup.com/en/article/36209 was also a big help.

Thanks again!