Latest update - Apple Pencil not aligning with nib location

Hoping someone can help me.

I have updated to the latest version of Sketch Up for iPad. All was working fine up until that point, however I now have a very weird anomaly.

When drawing with my Apple Pencil (and finger in fact) the point at which the drawing starts (corner of a rectangle etc) is 2-3cm away from either the nib or point of contact for my finger.

I’d assumed an issue with the pencil, until I discovered the same with my finger. BUT using the pencil to select any menu items or tools is doing so correctly, just not on the canvas.

Even stranger, the freehand drawing tool and nip are aligning, but then when the shape is complete it drops it 2-3cm away from where it is drawn!

Driving me mad. I have done the usual, delete and reinstall, hard reset, re sync pencil etc. There’s no issues apart from this app and the specifics outlined.

Thanks Darren

I just posted about having the EXACT same problem….hope someone can help us out!

1 Like

Thanks for posting this! I’m having the exact same issue. But this was posted 12 hours ago and there’s no resolution yet? Need some guidance please!

See Sketchup team reply here.

1 Like

@Mancunia @thirdeyeghost @Cie

Please accept our sincerest apologies for the trouble that you are experiencing with this latest release of SketchUp for iPad.

Know that our team is working hard to find a permanent solution. In the meantime, we have a test build that includes some changes that we’re hoping will get you back on track, and help us trace the root cause of the problem.

Please follow these steps to install the test build:
1) Install the TestFlight app from the Apple App Store
2) Click this link to join the TestFlight group for SketchUp.
3) Install SketchUp for iPad v6.5.1 (2063) from within the TestFlight app.

We would greatly appreciate it if you could report back and let us know whether you still see the same cursor offset issue in v6.5.1 (2063).

Note: Due to some of the changes we’ve made to v6.5.1 (2063), you will not see the option to use Ambient Occlusion in this test build.

See the latest post below for a better update.


Hi Mike

Super fast work, thanks for that.

I’ve just tested that and all seems to be working correctly for me!

Thanks Darren

1 Like

Glad to hear that it worked for you!

The team discovered that resetting the Display Zoom setting to the Default option, as shown below, should resolve the issue.

We will continue working on a permanent solution that will allow you to return to using the More Space setting.

Tried to resetting the Display Zoom setting to the Default option.
It works👍🏻!!!
Thanks Mike

Excellent. Glad to hear!

This Apple Pen aligning problem has made impossible to continue my design tasks and obligations now over a week. I do not have a possibility to wait much longer. If you cannot fix this problem I have to change the application and the company. So please, solve this problem ASAP.

Did you try the suggested option?

Please, specify which options.

perjantai 19. huhtikuuta 2024 Jack de Moel via SketchUp Forum <> kirjoitti:

Two posts up:

This is a quick end-of-day update to share that SketchUp for iPad v6.5.1 was released earlier this morning via the Apple App Store. The release includes a fix to the cursor offset issue.

After updating to 6.5.1, you should be able to restore your Display Zoom setting and find that SketchUp behaves respectfully. Thank you all for your patience as we worked to resolve this issue.