Apple pen not aligning properly

All of a sudden the Apple pen is not aligning on the iPad screen (forum won’t let me upload screenshot as I’m a new user)…for example when using the rectangle tool the tip of the pen should be at the corner of the rectangle, but instead the rectangle appears about an inch or so to the right of it. This is the same with all other tools. The pen works fine in all other iPad programs. I’ve been using Sketchup Pro on iPad for about a year with no issues. All systems are up to date. Tried hard reset. Tried uninstalling and reinstalling the app. Thoughts?


I’m having exactly the same problem-it started today.

You can see in this rough video it basically renders the ipad version unusable.
Ipad Bug
Ipad OS 17.4.1 M1 GPU
Sketchup version 6.5.0(2062)

1 Like

Hello all, apologies for the issues that you’re experiencing with this latest release. We’ve seen a handful of reports today regarding this issue. Please know that the team is working to trace the root cause of the issue and devise a solution.

Thank you for responding. This is a real mess. I’m in the middle of a project that I need to present on Tuesday morning and was worried it was my iPad. So happy to hear you’re working on it.

Same problem here.
Its worth saying that the pencil accurately tracks everything else such as links, buttons and controls on the screen, its just the drawing itself that seems to show this problem.

@Cie @Nano @Box @ppcjoinery

Please accept our sincerest apologies for the trouble that you are experiencing with this latest release of SketchUp for iPad.

Know that our team is working hard to find a permanent solution. In the meantime, we have a test build that includes some changes that we’re hoping will get you back on track, and help us trace the root cause of the problem.

Please follow these steps to install the test build:
1) Install the TestFlight app from the Apple App Store
2) Click this link to join the TestFlight group for SketchUp
3) Install SketchUp for iPad v6.5.1 (2063) from within the TestFlight app.

We would greatly appreciate it if you could report back and let us know whether you still see the same cursor offset issue in v6.5.1 (2063).

Note: Due to some of the changes we’ve made to v6.5.1 (2063), you will not see the option to use Ambient Occlusion in this test build.

Please see the latest post below for a better temporary workaround.

1 Like

Hallelujah! it works! Thank : )

Yep. Happy to confirm that that is working well, Thanks @MikeTadros for getting that resolved so quickly.

I’m not having the problem in my current version on iPad which is 6.5.0, but when I log in to Test Flight the only version I see available is still 6.5.0, not 6.5.1.

And I’ve tried refreshing the page in Chrome and Test Flight.

Ah. After waiting a couple of minutes, 6.5.1 has magically appeared and is downloading.

I’m not seeing 6.5.1 myself, but I don’t think I was seeing the problem anyway.

There would be no point installing it if you don’t have the issue, you would just be removing ambient occlusion.

The team discovered that resetting the Display Zoom setting to the Default option, as shown below, should resolve the issue.

We will continue working on a permanent solution that will allow you to return to using the More Space setting.

1 Like

OK, my old iPad doesn’t even have that option even though I’m on 17.4.1.

Correct – the option is available on iPads with an M-series chip running iOS 16 or newer. The iPads of the users who have reported this particular issue all fit that description.

Can I revert to the previous version to recover the use of Ambient Occlusion? If so, where do I find it (v6.5.0) in either Test Flight or the Apple Store?


I updated before realising what Box pointed out - I didn’t have the problem in the first place!

Found 6.5.0 in the Apple Store, installed it, and it seems to have overwritten the Test Flight version.

Hi, today it’s happened the same to me.
Taking measurements of an apartment and impossible to draw it in my SketchUp 4 iPad.
Phase lag between the Apple Pencil tip and the screen.
Tha Apple Pencil works properly in other apps like Morpholio trace or concept app, it happens only in SketchUp 4 iPad.

This is a quick end-of-day update to share that SketchUp for iPad v6.5.1 was released earlier this morning via the Apple App Store. The release includes a fix to the cursor offset issue.

After updating to 6.5.1, you should be able to restore your Display Zoom setting and find that SketchUp behaves respectfully. Thank you all for your patience as we worked to resolve this issue.

1 Like