Labs Geo Location

I have been trying to use the new add location function from Labs, I have a model that I was able to geolocate in Washington DC with the labs function, that reverts to Nisswa, MN on a lake any time I re-open the add location feature. The old geo-location feature, and add more imagery maintains my global geo-location. I haven’t seen the same problem in other models, so I may just move geometry to a new file, but perhaps someone else has seen similar problems. Also, this module seems to make my entire computer very unresponsive. The attached image is a screen grab of existing geo location geometry and the labs window with where it thinks the model is geo-located.


I just tried to locate a model with add location labs in Washington, DC and the location is matched between add location labs and existing add location. I am using SketchUp 2023 - your profile says you are on 2022, is that correct?

Can you please check that the extension is up to date (in extension manager) and update it if not.

If that doesn’t resolve the issue, what are the latitude/longitude values shown in the Sketchup Model Info window under Geo-location, and which place to they correspond to?

Regarding unresponsiveness - what kind of actions are you finding slower or with what add location operations do you see this? It’s now possible to bring a lot more elevation data into SketchUp than before which will put more strain on the machine - could this be the cause?


I’m having a similar problem. The Model Info says my model is not geo-located, but the New Add Location tool shows a geolocation that I can’t remove. Clicking the garbage can and clearing the geolocation inside of the tool has no effect.

Hey Dan,

Forgive me, I need to update my profile, I am on 23 Studio.

The plugin is the latest version.

All actions are affected by the plugin running (not when downloading geometry, or after geometry is placed, just open on the screen). Typing becomes very choppy, web browsing is unreliable, app switching, etc. I opened resource monitor to see if there was an indicator there. Network activity definitely sees some spikes while it is running, even if it is parked and not actively searching a location or downloading, during this time I also see an unusual amount of disk activity even if there is nothing that normally would be reading or writing to disk.

There is a ton of available RAM and processors show very low activity.


Are you using a large (10s of thousands of polygons) SketchUp model? That can cause SketchUp to become unresponsive while add location generates the ghosted model. It’s something we are currently working in improving.

In the meantime you could try disabling the “show model” option in add location to see if that helps.

However the way that shows itself for me is that the rest of the system stays responsive and just one core gets CPU loaded by SketchUp so I’m not very confident this is the issue.


I almost exclusively work with very highly detailed, high polygon, high resolution texture, models. This one is on the very light side of things still for my general workflow (only 165mb).

Feels like the show model portion of the new import geometry feature is the best part. Turning it off would put the tool back to the original limitations, importing geometry, then manipulating it to be in proper position for the model and manually setting geographic North, and if there is need to import more geometry, having to then manually move that into place after import as well. Not end of the world stuff, but looking forward to not having to. I might just take the envelope of this model, import it to another, clean, SU file, geo-locate with geometry, then import the rest of the model and go from there. Any further imports of geometry or 2D location info won’t need to show model after that.

1 Like

For the issues with the location status, this seems to be harder to reproduce. I think we’ll be best to take it off the forums so we can get to the bottom of it.


I totally agree with you about the importance of getting show model working with larger models - it’s something we are putting our efforts into to avoid workarounds.

An easier workaround than importing the envelope to another file would be to turn off visibility for as many groups as you can in the outliner - invisible groups don’t get rendered. Note that tag visibility won’t make any difference here!


I’ve found a clue to why/when the Add Location (Labs) tool shows a location that is incorrect and can’t be deleted. In my case, having any components in the model made this happen, because the components have a geo-location (don’t know why). Removing the components and purging the file did not solve the issue. I had to start from a blank file and manually remove geo-locations from the components before re-adding them. So, not really a solution, but a possible source of the problem.

1 Like

Quick update on where we are with these issues:

  1. Geolocated components causing geolocation: fixed in extension v1.4.7 (released 23 Jan)
  2. Computer slowdowns with large models: fix in progress. In the meantime please disable the “show model” option

Thanks for the feedback, it’s really helpful for us!