Just upgraded to 2023 on a Mac--weird file save error. No, it's not locked!

I just installed SU Pro 2023 on my MacBook Pro and have had a couple miscellaneous bug splats, an issue with authorizing an extension, and now getting this “could not be saved” message. I can save as a new file, but I can’t save to the old file. I don’t think this is going to be a big problem, but I’m a bit unnerved by all these little bugs. This is my 5th major upgrade and I don’t recall having issues like this before–everything just worked. This time I already have a couple hours into trying to get everything running right.

Did you install the installer file by running as administrator?
If not this can cause issues with writing permissions.
You could do a repair, find the installer file, ( probably in your download folder) right click on it and choose: run as administrator.
When prompted choose repair.
This should only take a few minutes and could be the solution to your problem.

it’s on mac, we don’t install sketchup, we simply copy it in the application folder, no permission problems like that on sketchup itself ;).

———

ok, first, could you confirm you installed Sketchup the proper way, meaning you dragged it in the application folder, you’re not running it from some other place ?

then, did you do what the message prompts you to ? select your file in finder, right click on it, get info, and check if you have the permission on it ? or if it’s unlocked ?

what if you save as ? are you able to save this file in a different location ? (if so, it would indicate the file or location has a problem)

are you working locally or in the cloud ? first, best practice to avoid trouble work locally, and if you’re in the cloud, do you have full permissions for it ? The last version of macOS is a dragon when it comes to security permissions, and it could see SU as an outsider not worthy of trust.

1 Like

Sorry, missed that completely…

1 Like

yes.

This confused me a bit since I’ve never encountered this before. The file is locked but I have read/write permissions. All my SU files are locked --including the new ones I created after the upgrade. In fact, all my files of any kind appear to be locked. I assume this is normal and it’s my permissions that allow me access.

I can save-as with the same file name to the desktop without problem. When I open the file from the desktop, I can re-save it there without problem. So maybe it is a location problem-- but what? My SU document folder has the same permission settings as everything else, and it has no problems with saving my new files since the upgrade. I’m going to try disk repair…

locally

Thanks for your help!

hahaha locked where ? top or bottom ?

if you’re talking about the bottom lock it’s normal, it’s to avoid people touching stuff and making mistakes without typing a password.

If the top one is ticked THEN you’re actually locked.
Capture d’écran 2023-07-28 à 20.00.49

if so, you can see a teeny-tiny lock on the file icon appearing.

Since you describe all your files as locked, I assume it’s the bottom one. all file top locked would be weird.


This would make me think the file you can’t save is right now in a folder you can’t touch.
Where is you “SU document folder” you mention ? did you create it yourself ? or are you working in a pre-made folder ? I’ve seen people sort their files in the same SU2023 folder where the app is located, except the Application Folder is protected, you can’t delete stuff without a password (again, to avoid stupid things).

From what you describe, it seems that somewhere in the file folder stack there is a folder that don’t allow SU to erase the previous version of your file.

at least we know it’s all clear on your desktop, so already, if you need to work, you can do so. Just create your folder containing your 3d on the desktop while we look for the answer.

Only the bottom. Top unlocked.

Folder seems fine. I did save-as with the file to the same folder with a new name and it works fine.

A folder on my desktop I created years ago that contains my SU documents. It’s not in the applications folder.

This is not really a problem going forward, I just hope it’s not a symptom of some bigger problem.

Thanks!

1 Like

You could try running the disc utility first aid - that will correct any permission errors.

However what is more likely is that there is another program “using” the file.
Anti virus or a file backup solution are usually the culprits for that.

1 Like

Capture d’écran 2023-07-28 à 20.50.39
what you could also do is in the info panel, bottom (once unlocked), you can see I have both admin and user permissions. since I’m admin, it’s the same.

what you could try is to delete the user permission (if you’re admin off course), then add it again (with +)

then on the (…) icon, you can ask to apply it to everything inside.

It will re-apply the permission to all the folders inside this one.
that, plus what Adam said, in applications / utilities / disc utilities, select your hard drive, and press the SOS on top. it’ll check if all is going well and if not, repair authorisations.


plan C would be… create a brand new folder, and put the content of the old folder in it. eventually take time to create new subfolders aswell, copying only the actual files from old to new. if it works fine after that, then yeah, one of the old folders was at fault, either permissions or another program not playing nice.

———

edit : or your SU file is somehow corrupted. If only this one or a couple of files are problematic, I would advise to save as into a fresh new file, and remove the old ones.

Ran disk utility multiple times. No change. Don’t know what other program would be using the file. No antivirus or automatic backups running. This behavior only started when loading a 2022 SU file into SU 2023, then try to save it again under the same name. I can certainly rename, and do so regularly as I make incremental changes to the file.

It wouldn’t allow me to delete the “me” permission. I tried adding an administrator (since I don’t have admin privileges designated anywhere–only “me” privileges). But it still wouldn’t allow me to delete the “me” privilege.

I don’t think so. File otherwise behaves fine. But more importantly, every SU file I have from prior versions exhibit the same behavior when trying to re-save. Interestingly, if I drag any of the files from their current folder to another folder --even one with other SU files that act the same way --it will save in that new location. I tried starting with a fresh folder and dragging all the files into it and that didn’t work. It’s some kind of location issue that I can’t pin down. It’s weird–never seen it before–but I don’t see a significant problem going forward as I continue to resave files under new names. Do you think it’s something more serious that I should track down? I’m thinking that rather than a file or folder permissions issue, maybe SU tracks file locations and the version change through it off? Just a wild ass guess…

Type lsof (don’t press enter) into the terminal then drag a file that is unable to be edited into that and then press enter.

That will list any process using it - it might be worth trying that.

You can also do a permissions specific diskutil command

diskutil resetUserPermissions / `id -u`

Any file I drag into terminal after lsof results in “No such file or directory”. I rarely go into terminal as it’s pushing the limits of my computer expertise, but this doesn’t seem right. I did a hard reset (which scared me a little because I don’t know what I’m doing) but nothing works with that command. I tried with and without a space after lsof–no luck.

OK, this problem is starting to get ugly since after a short period of time, files I had previously “cleaned” by using save-as to “new-file-name” will no longer save to that file name. I’m getting the same “could not be saved” message again. What’s really weird is I could save them without renaming for a few minutes, but then I started getting the error message again. It’s almost like there’s some background process that is reindexing the permissions for SU (even though I see no actual change in the file permissions).

I’ve now spent 6 hours running disk utility, fsck, and resetting user permissions via terminal, as well as doing all the same in recovery mode and using the terminal command “repairHomePermissions”. No luck. It definitely seems like Sketchup isn’t recognizing my authority to write to these files despite all the permissions appearing to be in order. I also reinstalled SU 2023. I have to emphasize that I’m very conservative with my computer use and upgrades. I don’t do crazy stuff and am not on a network. I started with Sketchup in 2016 and have upgraded every year since and have never seen anything like this. Any advice on other things I could try would be welcomed!

Minor update: a newly created file using SU 2023 that I saved to the same folder as older files does not have the issue. So it’s only files created in older versions and opened in 2023 that won’t save over themselves. Despite the new file behaving correctly in the old folders, my next step is test the folder structure since it seems that files re-saved to the desktop don’t have this problem.

When looking at a folder that has files that won’t save, type Command-J, and in the options that show, make sure iCloud Status is checked. Then get a screenshot showing the iCloud Status column. It will be something like this:

Thanks, but I don’t use iCloud so those are all grayed out. Despite a clean bill of health by Disk Utilities run on each volume in recovery mode, I suspect one or more of my folders containing these files is somehow conflicting with SU or otherwise corrupt. (*Note: I can still open and re-save these files using SU2022 without any problem, so it’s exclusive to 2023).

When I get more time later today I will try rebuilding the folders and migrating the contents. My initial tests indicate the files act fine if I move them (or re-save them) outside of their folders–not sure which method is preferable in this case. Also not sure where in the folder hierarchy the problem resides or if certain methods of migrating the contents may drag the problem into the new folders (That seems to have happened in earlier tests). More tedious testing ahead. I’m fairly confident I can fix this, but when I fix stuff I kinda like to know what exactly I’m fixing!

Just throwing something out, I don’t speak Mac, is it a possible case of a failing disk or drive?

Though I can’t say with absolute certainty, this doesn’t seem like what one gets when a drive is failing. It sounds much more like a misconfiguration of some sort. But I doubt that anyone can figure it out without hands-on of the problem computer. I’d say take it to the Apple Genius Bar and see if they can sort it out.

Nothing would make me happier! Flip a toggle or something and move on. But I’m conservative and don’t mess with settings I don’t understand. The only thing that changed on my laptop was upgrading SU–which I did by the book. Something is telling SU 2023 (but not earlier versions) that I don’t have permission to overwrite an existing file.