SU 2014 Crashes when saving/opening dialog appears on OS X


#1

It’s definitely not a Yosemite specific problem - because I had the same issue with SketchUp Pro running on Mac OS X:

Saving and opening files mostly lead to a crash of my SketchUp Pro installation.

Some examples (and workarounds):

Creating and saving a new file … normally crashes before the standard Mac file dialogue appears.(DATALOSS)
Only workaround, so far: Save the file right after opening it without doing anything in SketchUp. If I create some 3D stuff after saving the pure new file I can save those changes … most of the time Sketchup also crashes, but just after saving the SketchUp file.

Saving an existing file … normally crashes after the file is written to the disk.(NO DATALOSS)
Workaround: Be sure that you always only need to save one of your open files … as the other files will be doomed with the crash.

Save-As an existing file under a new name … normally crashes before the standard Mac file dialogue appears. (DATALOSS)
Workaround: Create a duplicate of the file you want to “save as” in the finder and open it in SketchUp … then you can just save it. This also crashes Sketchup … but as said before: it crashes after saving.
Second Workaround: If you already changed the SketchUp-file, but want to preserve the old file, you switch to the Mac Finder, duplicate the file you are working on right now. Then you just use the save command in SketchUp. SketchUp will crash after saving the file. So now you can rename the two files so that everything is ok again.

Import file … bringing up the standard Mac dialogue mostly leads to a crash. (DATALOSS)
Workaround: Sometimes it helps to open the SketchUp-file, save the file and then go on with the import.

Things I did to solve the problem, but did not help:

  • Repaired file permissions on my Mac.
  • Deleted all SketchUp-related preferences.
  • Reinstalled SketchUp Pro 14.

System Specs:

  • Mac OS X 10.10 (14A388a)
  • SketchUp Pro 2014 14.1.1283

#2

These problems sound a lot like you have a misbehaving plugin or extension. Have you tried culling them down to see whether you can eliminate the problems that way?


#3

@slbaumgartner: Thanks for the reply. But I tried to deactivate all plugins … no change in behavior.

Only one thing bothers me: When I try to make a complete clean install … wipe out all preferences and app support files and folders, delete all sketchup apps and empty the trash: When I reinstall SketchupPro everything is there again: Licence info and also all 3rd-Party plugins?! I contacted Pro-Support … hopefully they’ll come up with a solution.


#4

At the risk of insulting you, if everything comes back you clearly did not wipe out everything, which may also tie in with why turning off plugins did not change anything!

For SU 2014, user-specific items such as licenses, plugins, etc. are in subfolders of “~/Library/Application Support/SketchUp 2014”. Your preferences are in "~/Library/Preferences/com.sketchup.SketchUp.2014.plist. There should be nothing in “/Library/Application Support” or “/LIbrary/Preferences” for SU 2014 unless you set up a multi-user shared installation. But if you did, the items may be coming back from there. SketchUp on the Mac does not use any hidden folders or mystery locations to store anything. A fresh install overwrites the Application bundle, so nothing can lurk there.


#5

@slbaumgartner: you’re not insulting me.

In fact: I double checked both of the locations … and boom: “~/Library/Application Support/SketchUp 2014” still was there. Strange fact: I did not find it when I searched for any folder containing “SketchUp”. So this is probably my personal Finder-Search-Engine problem.May have to re-index.

So, deleting “~/Library/Application Support/SketchUp 2014” resulted in the intended fresh installation and solves the pesky crashes when saving and importing a file.

The only problem I still have, is a crash if I try to open or create a new collection in the Style window. It should also open the normal Apple file dialog. But it crashes the SketchUp.
But there is a handy workaround, so unsolvable problem left:

  • open the “Ruby Console” in SketchUp in the “Windows” main menu
  • Type:

Sketchup.find_support_file(“Styles”)

  • This will output the exact path to you Styles folder in the App-Bundle.
  • Use the Finder command “Go to Folder…” and input that path. This will open that folder - normally hidden in the app-bundle.
  • Create new folder for your personal style collection
  • Put in the intended styles.
  • Restart SketchUp.

So, thanks again @slbaumgartner, for solving most of my problem.


#6

btw … just installed SketchUp Pro 2015 … this even solved my last problem with Styles … so hopefully I can focus on modeling again :smiley:


#7

Do you know how can I install SU (free download) for MAC OSX 10.5 ???

thanks!


#8

I believe that SketchUp no longer supports anything before Mac OS X 10.8. Sorry!