Jerky zooming is back!

Afternoon all,

Out of the blue I seem to be having issues with really slow/jerky zooming & navigating in my model. It barely has anything drawn in it as of yet (a few kitchen cabinets, and a small AGA component which I’ve used for ages without grief).

I’ve updated SU to the latest version of 2020, updated my GPU driver and cleared my computer of temp files etc etc, and it still seems to be struggling.

I ran the SU checker tool, and got this:

SU check

Does this mean something is wrong with the GPU? It’s never been a problem before…

I don’t think I will be able to add any details to get it ready to render, it’ll be so slow!

As always, all help appreciated greatly!


What you are seeing is a known bug in the way windows reports to the Check up request.

What you describe is generally related to the graphics card/drivers. Since this just started and updating the graphics drivers didn’t improve it, here are a few things to check.

Make sure your recent SketchUp install was done correctly. To do that close SketchUp and LayOut. Right click on the downloaded installer and select Run as administrator then choose Repair. After that, shut the computer down and restart (cold reboot). Open SketchUp and go to Window>Preferences>OpenGL and click on Graphic Card Details. Make sure it’s telling you about the Nvidia GPU and not the integrated GPU.

Check to see if performance has improved. If not, you can try changing the state of the Use Fast Feedback tick box and see if that helps.

When you updated the graphics drivers, did you do that directly from the manufacturer? Or did you just let Windows check for updates?

It might be that you’ll need to roll the drivers back to an earlier version.

As Dave points out, the warning about the graphics card in CheckUp can be ignored. CheckUp exposes a Windows bug that is supposed to report information about the graphics card. Basically CheckUp is just passing on fake news. :wink:

Thanks @DaveR & @RLGL, I’ll try what you suggest now.


fake news

1 Like