Issues with ClothWorks on MacOS Sonoma

I am writing to inform you about a significant issue I’ve encountered after updating my system to MacOS Sonoma. Recently, I upgraded to Sonoma, only to discover that the ClothWorks plugin is no longer functioning correctly. This unexpected problem has caused a considerable inconvenience in my workflow.

I am reaching out to inquire if anyone else is experiencing similar issues with ClothWorks on Sonoma. Any insights or solutions would be greatly appreciated.

Furthermore, I would be grateful for any information regarding other plugins that may not be compatible with Sonoma. Sharing this knowledge can help me and others who rely heavily on these tools for our daily tasks.

As an M3 MacBook user, downgrading the system is not a preferred solution for me. Despite the current challenges, I recognize some benefits of switching to Sonoma, such as improved responsiveness in Layout and smooth performance even in hybrid mode.

Your assistance and any suggestions you might have would be immensely valuable. Thank you for your time and attention to this matter.

Sincerely,

There are a few threads about SketchUp and Sonoma, you can use the search option to find them.
Sonoma is not yet supported by SketchUp and causes trouble for some users. Other users are not experiencing these troubles…
I’m guessing that extensions can only be made supportive AFTER SketchUp supports Sonoma…

Best practice for everyone who relies on software is to make sure to check if that software supports a new OS BEFORE upgrading!
Even better is to wait untill most of the wrinkles are ironed out before doing so…

1 Like

“Support is from now on,” that was indeed the case. I have circumstances where I need to get a new Mac…
I hope that various aspects will improve with support!

1 Like

I see where having to purchase a new computer (which most of the times have the latest OS installed) can cause trouble with things not being compatable/supported…
Maybe not an obvious solution but you can ask for an OS downgrade to prevent compatability issues…

Clothworks is working for me in Sonoma. It may be worth asking @Anton_S if he knows of Sonoma issues.

Are you still using SketchUp 2022 as your profile shows?

Thank you for the information! I’ve tried several times, but in my case, pressing the play button always results in a crash. By the way, my Sonoma is version 14.2.

Since it seems to be working fine for others, maybe reinstalling Sketchup could fix my issue.

However, I have a large number of plugins, and just like with regular updates, I hesitate to proceed because of the time involved… But I am hopeful, knowing that it works for others!

Resinstalling SketchUp shouldn’t disturb the extensions.

1 Like

The current version is 2023.
I apologize for not updating the profile sooner, it has been updated now. I also tried reinstalling the application, but unfortunately, it still didn’t work…"

Thanks for updating your profile.

What exactly happens when you try to run Clothworks?

Can you share the .skp file so we can try it on other macines to ensure it’s not the model?

Thank you for your response. I am writing to inform you about a specific issue I am experiencing with the Crothworks software. The symptoms are as follows:

Starting in a model-less space, when I apply a cross setting to a simple square (the issue occurs even without the grid setting), the software crashes upon pressing the play button. This crash happens whenever I try to play any simulation.

Additionally, my Mac OS is not a beta version; it was recently updated to version 14.2.1. I believe the last operational Mac was running on the 14.3 beta version, but I have not upgraded to that.

This message is to report the current situation. Looking forward to your guidance on resolving this issue.