Issues Duet display app causing Sketchup to crash

Hi All,

I have just installed the screen mirroring app Duet so i can use my iPad as a second monitor. When i try to open Sketchup 2018 Pro, it crashes. I see that there was some discussion regarding this last year but can’t find whether there was a resolution to the problem??

Please help Sketchup team. I would hate to not be able to use the Duet app for monitor extension.

Thanks for the help in advance.

1 Like

Apparently Duet doesn’t support OpenGL, the display system behind SketchUp. I have had similar problems with some USB laptop docks.

1 Like

Thanks Anssi. Am i then to assume that this is a Duet issue to deal with or can i ask the Sketchup team to try to create a work around (i am sure they are busy or anything :grin:)

Considering that SketchUp has always required graphics cards/drivers to support OpenGL, it’d be pretty silly to expect they are going to make a change in that for you.

Maybe you can get Duet to support OpenGL.

Thanks DaveR. I am not technically savy when it comes to computers so done know all that stuff. I have sent Duet a query so lets see what they come back with :slight_smile: I will return with their awnser if you are interested.

Currently Duet won’t get past the launching screen on my iPad, so I can’t test the problem. But, I notice that in the settings menu there is a Graphics card option that you can use to set whether it’s using discreet or integrated graphics. Could be worth trying the other one.

As the iPad is connected over USB, and not a display port or Thunderbolt, I’ve assumed that it’s doing a screen sharing thing, it isn’t directly driving the iPad screen. So maybe OpenGL apps should work without crashing.

@mikelucey mentions he has tried it click here


I couldn’t see any mention of using SketchUp with Duet. also, that was two years ago, before SketchUp required OpenGL 3.

It doesn’t on mac…

v18 runs fine on OpenGL 2.1…


Well, I meant > OpenGL 2.0. I have to keep 2016 for testing under Windows (in Parallels) because that only does OpenGL 2.0. I doubt many Macs are below 3.3:

Hi All,

Thanks for the help and the comments. Duet has responded to me with the fact that they are dealing with the issue and the next update will fix the problem. There predicted release of the update is the end of March.


Thanks, I’ll watch out for that.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.

I reached out to Duet and here’s what they said:

We appreciate the fact that you’ve brought this to our attention. I’ve been doing some tests and I’ve been unable to reproduce the crash so far.

However, if possible, could you inform the users experiencing this issue to contact us?

We will strive on fixing this incompatibility as soon as possible.