Issue with slow animation render times

I am having trouble with vray while rendering any animation. For the first 10-15 frames everything is fine frames are taking around 1 minute on average then I start to get a warning on the vray log window saying num samples per thread reduced to 327170, rendering light be slower then next frame reduced to 276348 then on and on until it reaches 32768 and at that point my renders are taking 10-20x as long each frame to complete then the first 10. This is happening when I render using rtx and cuda mode, doesn’t happen when using cpu. Any suggestions would be greatly appreciated thanks.

Im using vray 2023 for sketchup on pc with gpu 4070

What happens when you render just one of the scenes that are taking longer to render in the animation?

Do you mean just one frame ? I’m not sure I understand what your asking sorry, the scenes are about 5 seconds long so around 180 frames I can’t get past 15 frames without it slowing down so what I’ve been doing is restarting the renders starting at the last frame completed and the process repeats itself. Need a solution so I can let the renders work without me being there to restart everything every 20 minutes.

Sounds like you are running out of memory. 32768 is a magic number which is 2 to 15th power.
What happens when you watch the memory usage etc.

The ram is constant at 15.3 gb I have 32gb total
I have a GTX 4070 12gb
The dedicated GPU memory starts around 6gb and after each frame it climbs by 0.5 gig and when it gets to 11.4 gig it starts to slow and the error message in the log window I mentioned begins so seems you are correct in assuming there is an issue with the memory. Is there a work around to prevent this or a setting I can change ?

You´re running out of video memory, that´s why it doesn’t happen when you render with the cpu, cause you have 32 gigs of memory while just 12 gigs of video memory.

You could render with the cpu or work on the scenes that consume more memory, I havent seen the model but i guess you have assets with a lot of polygons, maybe more artificial lights or probably volumetrics, those things consume more memory.

Ok I understand but why does the vram continue to rise after each frame it has no issue rendering one frame it gets saved and then it should move on to the next frame why is the vram demands being increased after every frame ? Sketchup is outputting individual frames and rendering them individually. Sorry if these of obvious questions I’m new to this. How do people do large animations that have hundreds of frames in one batch even with a 4090 and 24gb of ram it wouldn’t take long to have the same issue Im having with 12gb. I just did a test rendering with my cpu and my ram usage stays the same even after similar number of frames as when I used the gpu.

I’m hoping to bump this up to also get an answer.
I’m working on a 540 frame rendering with vray plugin, and my computer works perfectly quickly for about 20 frames, but after 20-25 frames it slows to a crawl.
Simply stopping the rendering and restarting solves all the speed problems, but requires manual input every 20 minutes.

In previous searches about this problem I heard that Dynamic memory limit should be set (but we can’t adjust that with vray in sketchup) or turn off progressive (mine is already turned off).

For example, this thread from the Chaos support website has plenty of potential solutions, most of which aren’t applicable in Sketchup

Is this a problem that Sketchup simply doesn’t have the features to fix?